Dragonfly CMS v9 ⇒ Coppermine :: Archives ⇒ admin not accessible in coppermine :: Archived (page 2) ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexModules & Blocks Coppermine ⇒ Archives

Archived ⇒ admin not accessible in coppermine


i had the same problem, thanks for your solution

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux jota 2.4.29/Apache/MySQL:4.0.18-standard/PHP:4.3.10/CPGNuke:9.0.3.0


Yup...same here. Same problem..thought I was going crazy.. Neutral

Why is it that there's always more month at the end of my money?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.0.25-standard/4.3.10/9.0.5.0


man I must be blind

did the sql above and the cache and the cookie thing

Rolling Eyes Confused

I tapped into the gallery config manually in the url

but cannot do the same with 'catmgr' - 'don't have permission ... '

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.0/4.1.12-nt-log/5.0.4/9.0.5.0


DOH

nm

you have to do this in addition to this thread

dragonflycms.org/Forum...11467.html

The key being this:
admin > ranks > create the rank you want and set it as a special rank. ( site admin )

Well that's what seemed to work for me anyway Big grin

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
xp/2.0/4.1.12-nt-log/5.0.4/9.0.5.0


This didn't quite work for me. I have my coppermine gallery setup and working under "eGallery". It was working on 9.0.4, but once I upgraded it is experiencing this issue.

I have added the field to the cms_admins table, changed my member and admin cookie (both for the site and the gallery). I have cleared my cache folder, cleared my browser's cache (firefox). Even tried it on a PC that has never been to my site using IE 6.0 and still it won't work.

I can manually go to the config section, but I cannot do anything else manually. Getting the "Not Authorized" errors. Any other hints on something that may need to be adjusted to see that I am not using the coppermine directory? I have three image galleries on my site (all were working fine with 9.0.4).

Any assistance would be greatly appreciated.

EHP Webmaster
www.ehpdesigns.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS / Apache 1.3.34 / MySQL 4.1.22 / PHP 4.4.7/ DF 9.1.2.1


MikieMouse try adding via phpmyadmin
ALTER TABLE `cms_admins` ADD `radmin*` TINYINT( 1 ) DEFAULT '0' NOT NULL;
where * is the renamed coppermine module name

AKA Akamu / Read these and your life will be successful | Find a Repair
--
Mods and Professional Support via YIM

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
win32 / Apache 1.3.33 / MySQL 4.1.16/PHP 4.4/CPG-CVS ( browsers: Mozilla 1.7.x / IE6 / Opera 8.0)


akamu wrote
MikieMouse try adding via phpmyadmin
ALTER TABLE `cms_admins` ADD `radmin*` TINYINT( 1 ) DEFAULT '0' NOT NULL;
where * is the renamed coppermine module name


I've already tried doing that for each of my modules. There is a problem with the "IS_ADMIN" portion of some of the includes for coppermine that are not detecting me as an admin in versions of DF from v9.0.5 so I went back to that code from v9.0.3 and it works again. Though a couple other things did break but I can live with those.

EHP Webmaster
www.ehpdesigns.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS / Apache 1.3.34 / MySQL 4.1.22 / PHP 4.4.7/ DF 9.1.2.1


bah, i too had this problem, and it was no measely sql defeciancy; i already had all the neccessary columns; instead it was the fact that my admin area was still affect via register globals being off, ie a variable wouldn't be initialised with it's $_GET[] data, so i needed to do it explicitly.

I added the bugfix, but cvs file is still unchanged (i dont knwo why though).

replace this if (!defined('ADMIN_PAGES')) { exit; } if (!can_admin($op)) { exit; }with this if (!defined('ADMIN_PAGES')) { exit; } $op=$_GET['op']; if (!can_admin($op)) { exit; }

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (Kernel: 2.4.21-27.0.2.ELsmp)/1.3.33 (Unix)/4.0.24-standard/4.3.11/9.0.5.0


mc__ wrote
bah, i too had this problem, and it was no measely sql defeciancy; i already had all the neccessary columns; instead it was the fact that my admin area was still affect via register globals being off, ie a variable wouldn't be initialised with it's $_GET[] data, so i needed to do it explicitly.

I added the bugfix, but cvs file is still unchanged (i dont knwo why though).

replace this if (!defined('ADMIN_PAGES')) { exit; } if (!can_admin($op)) { exit; }with this if (!defined('ADMIN_PAGES')) { exit; } $op=$_GET['op']; if (!can_admin($op)) { exit; }


I have a coppermine icon in my admin section if i do this, if i remove it i no longer have one, if i put it back i do, if i remove it i dont, so i put it back and i do.

I think that that is pretty definite proof of this being the cause. seems pretty foolproof to me.

Now i don't know why not everyone experiences this issue (maybe their web account isn't fully priviledged like how mine is), but please reply saying if this fixed it, or it was something else.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (Kernel: 2.4.21-27.0.2.ELsmp)/1.3.33 (Unix)/4.0.24-standard/4.3.11/9.0.5.0


I'm still having this issue after upgrading to the latest version. (9.0.6.1).

I've done everything so far in this thread and I have no icon in admin panel and the only option I have is to manually type in the URL, but I only have the option to goto config. Anything else is access denied.

Can anyone offer any other suggestions?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.33 (Unix) / 4.0.20-standard / 4.3.10 / Dragonfly 9.1


UPDATE: It's working now. After finding another thread with this issue I realized I had forgotten to log out and log back in to admin to reset the cookie. It appears to be working now. Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.33 (Unix) / 4.0.20-standard / 4.3.10 / Dragonfly 9.1


akamu wrote
ALTER TABLE `cms_admins` ADD `radmincoppermine` TINYINT( 1 ) DEFAULT '0' NOT NULL;


i have make this on cms_admins but nothing
something else...

webalbania.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Php 5.0.4 /MySQL 5.0.26/DF CMS 9.1.1.RC2


akamu wrote
ALTER TABLE `cms_admins` ADD `radmincoppermine` TINYINT( 1 ) DEFAULT '0' NOT NULL;


Now is ok, with this it work:
ALTER TABLE `cms_admins` ADD `radmincoppermine` TINYINT( 4 ) DEFAULT '0' NOT NULL;

webalbania.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Php 5.0.4 /MySQL 5.0.26/DF CMS 9.1.1.RC2


I also had this problem with a fresh "update" load on phpNuke 7.0! This would be VERY good information to include in a .txt file with the install package.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1

All times are UTC