Miscellaneous ⇒ Chit-Chat :: Archives ⇒ Problems with setting Dragonfly on local Host :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexChit-Chat

Archived ⇒ Problems with setting Dragonfly on local Host


I am trying to setup my site on my local host by I seem to be running into some problems. Firstly the images weren't showing up but now they have started to show up.

But now I got into another big problem. I have LEO switched on and as it turns out none of the link is working except the /index.php one. Where could I be going wrong? I need help desperately to test a few features I intend to introduce my site. Thanks for the help in advance.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


Just to add on to what I said above, I am also not being able to log in to my Admin console. Hope this info helps!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


localhost = windows with xxamp or apache2triad or similar or on a linux box?

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2


I have tried them but with the same problems. As it turns out there could be two problems according to me. One a cookie issue or the other being an htaccess file issue. I tried something similar a few months back and succeeded. But that was a fresh install of DF. As of now I am recreating my entire present website. Help would be appreciated!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


in the database and /cache/config_MAIN_CFG.php are the server-domain and cookie-domain probably set to your website domain

Make them empty

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Can you please tell me as to exactly where in the database. As for the cache I already had emptied it!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


config table

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


It now seems to be a cookie and domain path problem. I have looked into the DB but can somebody please tell me the actual lines that I should be looking for to change them in the config template.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


config_custom

Here is my setup for my localhost on a box I've got running at my house. www.localsand.info:81/dragonfly/

server path /dragonfly/
server domain localsand.info:81
cookie path /dragonfly/
Delete cookie domain localsand.info
cookie admin bigern_admin
cookie member bigern_member
cookie server 0

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2


you can also ensure 'server domain' and 'cookie path' are in fact VALID, it should work even with just 'http://localhost/'

J.
j e r u v y a t y a h o o d o t c o m

Need help? Look here: www.dragonflycms.org/W...d=112.html
Need to chat? Look for me on irc.freenode.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu7.10/Debian3.1 - 2.2.3/1.3.37 - 5.0.38/4.0.27 - 5.2.1/4.4.7 - CVS/9.1.2}


Here is my edited config_custom table.

('cookie', 'domain', ''), ('cookie', 'admin', 'cms_admin'), ('cookie', 'member', 'my_login'), ('cookie', 'server', '1'), ('server', 'path', '/radopod/'), ('server', 'domain', 'localhost'),

I have added the ones that were mentioned by bigern. I have been constantly trying to log in and although everything else seems fine with the website, logging in is a problem. Dead sure that he cookie settings are at fault. Can somebody look into it whether the settings are correct.

NOTE:- I am trying to set up the site in a folder titled 'radopod'.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


Just to add on I have also tried this

('cookie', 'server', '0'),

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


server path /df/
server domain localhost
cookie path /df/
cookie domain
cookie admin cookie_admin
cookie member member_login
cookie server 0

This is on my ubuntu laptop with apache2, php5, mysql5

Make sure your cookie for admin and member are completely different than any other site you have or have been to. It needs to be unique.

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2


Problem solved finally earlier this morning. Thanks a lot for all the help!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.0.54 (Unix)/5.0.51/5.2.6/DragonflyCMS 9.2.1


Would you mind posting what you did for others that might come across this same issue? Very Happy

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2

All times are UTC