Support ⇒ Upgrades :: Archives ⇒ [fixed] 9.2 RC2 OPTIMIZE LOCAL TABLE :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

Archived ⇒ [fixed] 9.2 RC2 OPTIMIZE LOCAL TABLE


Hi there

I upgraded onto my test site ok but at the end of the install it showed an error ... the site however is ok and out of maintance mode so i will copypaste the code in here just in case you have not had this reported before....


[code]Database optimization. The execution of this step might take a while for a big database.

Database optimization. The execution of this step might take a while for a big database. ERROR On /install.php While executing query "OPTIMIZE LOCAL TABLE mp3t_tracks" the following error occured: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'LOCAL TABLE mp3t_tracks' at line 1 In: /home/radioget/public_html/testsite/install/step3.php on line: 141

cheers Tim

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL Version 5.0.45 PHP Version 5.2.6 apache is 1.3.41 Dragonfly 9.2.1 Windows 7


i can confirm "radiogetswild" post, i updated several websites and everything was ok, when i tried to update a website hosted by 1and1 i had the same bug ...

to be able to finish setup and reopen the website, i edited the file /indtall/step.php and excluded the optimization code like this:

// foreach($tablelist as $table) { // $db->optimize_table($table); // }

this allowed me to finish the installation, then i used phpadmin to "manually" update the tables

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (infong 2.4) - 1.3.33 - 5.0.45-log (client: 5.0.18) - 5.2.4 - 9.1.2.1


I dont think it missed out anything this end the site is fully running with all info so far as i can tell just that error but i will have it checked out...just in case cheers Tim

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL Version 5.0.45 PHP Version 5.2.6 apache is 1.3.41 Dragonfly 9.2.1 Windows 7


MySQL error? MySQL version please ....

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


i think its 4.01 or something like that it is gonna upgrade to version 5.2 in feb .. cheers Tim

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL Version 5.0.45 PHP Version 5.2.6 apache is 1.3.41 Dragonfly 9.2.1 Windows 7


@ you sure that you are using MySQL 5.0.45-log (client: 5.0.18) ?

@ radiogetswild update your server specs pls

[edit]
As a test could you both try to add a message (admin.php?op=messages) and delete it. Whn you delete you should get the same error, correct?
[/edit]

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


NanoCaiordo wrote
@ you sure that you are using MySQL 5.0.45-log (client: 5.0.18) ?


yes

hmmm i reuploded old db and old dragonfly 9.1.1 files, then i updraded to dragonfly 9.2.0 but this time there was no error

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (infong 2.4) - 1.3.33 - 5.0.45-log (client: 5.0.18) - 5.2.4 - 9.1.2.1


1) you cant edit your own post in this forum, that sucks
2)the error on some of my sites, where images dont show up in signatures is strange, if a include the image in a news article with hmtl code, i displays the image correctly, if i add the image to my signature with bbcode, it only shows the bbcode and not the image itself
3)i added a message like you said, no problem, then i tried to dekete it and got this error message

CMS Warning line 75: On /admin.php?op=messages&del=1 While executing query "OPTIMIZE LOCAL TABLE cms_message" the following error occured: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'LOCAL TABLE cms_message' at line 1 In: admin/modules/messages.php on line: 52"

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (infong 2.4) - 1.3.33 - 5.0.45-log (client: 5.0.18) - 5.2.4 - 9.1.2.1


ups ... i m really sry, the db in use for that website WAS NOT 5.0.45-log (client: 5.0.18) ... the db i used WAS 4.0.27-standard-log (client: 5.0.18)

now i have upgraded to 5.0.45-log (client: 5.0.18), install was no problem, then deleting the message was also no problem

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux (infong 2.4) - 1.3.33 - 5.0.45-log (client: 5.0.18) - 5.2.4 - 9.1.2.1


Code MySQL 4.0 backward compatible in cvs and it have been included in RC2 already.

Thank you guys.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


i just upgraded dragonflycms.de from 9.1.2.1 to 9.2.0.RC2

1.problem)
install / step 3 :

i can confirm "radiogetswild" post too

// $db->optimize_table($table);

with this i was able to finish the install

2.problem)
when i try to go to admin/modules i get again

"OPTIMIZE LOCAL TABLE" error in modules.php

i manually optimized all tables - not helped

then i see that i have in table cms_modules u got 2 foreign fields (left from an old wysiwyg module install)

i deleted this to fields and everything works now Wink

--------------

PHP Version 4.3.11
MySQL Version 4.0.21-standard (client: 3.23.58)

.: USE THE FORCE :.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


@ertan: yes you just installed, but your download is more then 4 days old.
If you read my answer

NanoCaiordo wrote
Code MySQL 4.0 backward compatible in cvs and it have been included in RC2 already.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC