Support ⇒ Troubleshootings :: Archives ⇒ IPs are 0.0.0.0 :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

Archived ⇒ IPs are 0.0.0.0


Hi!
When I check thr IP-adresses of the users of my site www.hellasforum.net most of the IPs are 0.0.0.0 Does anyone know why, and how to fix this problem?? When new users register the IP shows up well in the e-mail that I get.

Take a look at the attached file.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.34 / 4.1.13-standard / 4.3.11 / Dragonfly 9.2.1


Topic locked until Dylert correctly update his website url.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Unlocked, it's just missing a W

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


0.0.0.0 is caused by too many possible issues and each of them have a different fix.

1) incorrect MySQL connection/database/field encoding (you use DragonflyCMS 9.0.6.1 and so varchar fields)

2) 64 bits architecture OS

Fix 1)
Since you are using 9.0.6.1 and for sure moved from MySQL 4.0 to MySQL 4.1 (UTF8 by default probably) you need to change the encoding for your database, tables and fields.

Fix 2)
DragonflyCMS 9.2 (in RC2 stage atm) fix this.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC