Support ⇒ Troubleshootings ⇒ Missing images (file permissions) ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

Missing images (file permissions) Reply to topic


I have google this and tried the forum search I'm sorry if it is posted elsewhere.

I just completed my first install of Dragonfly (9.2.1) and I must say it looks spectacular. I was using Firefox and had no problems till i decided to test it on IE 7.0

When opening IE 7.0 there are numerous red Xs denoting icons that did not load. When checking the properties, the corresponding icons are found in their proper location.

The site: www.tmedweb.net/DHOTES.../index.php
A screenshot of problem: tmedweb.net/DHOTEST/pu.../redXs.jpg
FF screenshot: tmedweb.net/DHOTEST/pu.../FFnoX.jpg

Also a second quick question:
Is there any compatibility between phpnuke modules (since origins is nuke 6.5) or are they now completely separate entities?

I would very much appreciate some help in solving this problem.
~DHO
Attachment: redxs.jpg
Description A screenshoot of the problem
Filesize 161.37 KiB
Viewed 86 Time(s)
You are not allowed to view/download this attachment

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1


Not really a DF issue - the difference you report is because FF doesn't display red X's - the images are still missing.

Make sure you upload all files in the images directory.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


I have confirmed with FileZilla twice that all files are present in the correct location. I am currently replacing the existing images directory.

When I click on properties, I can see what the source where the images should be, and when I look on the server they do indeed exist.....

That's what confusing me the images do exist in the proper directory, but are not displayed.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1


hmm, not much we can do from a DF perspective - if they are there, then you may have some ftp transfer or server permission issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


I turned all debugging on and get this error involving the menu
As you said could be the server, but i figured worth posting

Array ( [theme] => default [session_time] => 1205380193 [menu_img] => Array ( [default] => Array ( [small/database] => themes/default/images/admin/small/database.png [small/help] => themes/default/images/admin/small/help.png [small/preferences] => themes/default/images/admin/small/preferences.png [small/bug] => themes/default/images/admin/small/bug.png [small/security] => themes/default/images/admin/small/security.png [small/info] => themes/default/images/admin/small/info.png [small/blocks] => themes/default/images/admin/small/blocks.png [small/cpgmm] => themes/default/images/admin/small/cpgmm.png [small/l10n] => themes/default/images/admin/small/l10n.png [small/modules] => themes/default/images/admin/small/modules.png [small/smilies] => themes/default/images/admin/small/smilies.png [small/authors] => themes/default/images/admin/small/authors.png [small/groups] => themes/default/images/admin/small/groups.png [small/users] => themes/default/images/admin/small/users.png [small/usersconfig] => themes/default/images/admin/small/usersconfig.png [small/ranks] => themes/default/images/admin/small/ranks.png [small/messages] => themes/default/images/admin/small/messages.png [small/stories] => themes/default/images/admin/small/stories.png [small/surveys] => themes/default/images/admin/small/surveys.png [small/topics] => themes/default/images/admin/small/topics.png [small/forums] => images/spacer.gif [small/newsletter] => themes/default/images/admin/small/newsletter.png [small/history] => themes/default/images/admin/small/history.png [small/banners] => themes/default/images/admin/small/banners.png [small/referers] => themes/default/images/admin/small/referers.png [small/headlines] => themes/default/images/admin/small/headlines.png [small/coppermine] => images/spacer.gif [database] => themes/default/images/admin/database.png [help] => themes/default/images/admin/help.png [preferences] => themes/default/images/admin/preferences.png [bug] => themes/default/images/admin/bug.png [security] => themes/default/images/admin/security.png [info] => themes/default/images/admin/info.png [blocks] => themes/default/images/admin/blocks.png [cpgmm] => themes/default/images/admin/cpgmm.png [l10n] => themes/default/images/admin/l10n.png [modules] => themes/default/images/admin/modules.png [smilies] => themes/default/images/admin/smilies.png [authors] => themes/default/images/admin/authors.png [groups] => themes/default/images/admin/groups.png [users] => themes/default/images/admin/users.png [usersconfig] => themes/default/images/admin/usersconfig.png [ranks] => themes/default/images/admin/ranks.png [messages] => themes/default/images/admin/messages.png [stories] => themes/default/images/admin/stories.png [surveys] => themes/default/images/admin/surveys.png [topics] => themes/default/images/admin/topics.png [forums] => modules/Forums/admin/forums.png [newsletter] => themes/default/images/admin/newsletter.png [history] => themes/default/images/admin/history.png [banners] => themes/default/images/admin/banners.png [referers] => themes/default/images/admin/referers.png [headlines] => themes/default/images/admin/headlines.png [coppermine] => modules/coppermine/admin/coppermine.png ) ) [mmimages] => Array ( [default] => Array ( [icon_unselect.gif] => images/blocks/CPG_Main_Menu/icon_unselect.gif [icon_cantselect.gif] => images/blocks/CPG_Main_Menu/icon_cantselect.gif [icon_home.gif] => images/blocks/CPG_Main_Menu/icon_home.gif [icon_community.gif] => images/blocks/CPG_Main_Menu/icon_community.gif [icon_members.gif] => images/blocks/CPG_Main_Menu/icon_members.gif [icon_forums.gif] => images/blocks/CPG_Main_Menu/icon_forums.gif [icon_search.gif] => images/blocks/CPG_Main_Menu/icon_search.gif [icon_web.gif] => images/blocks/CPG_Main_Menu/icon_web.gif [ images/blocks/CPG_Main_Menu/ images/blocks/CPG_Main_Menu/ images/blocks/CPG_Main_Menu/icon_select.gif ) ) [update_monitor] => Array ( [current] => 9.2.1 [url] => http://dragonflycms.org/Downloads/details/id=28.html [num] => 1 [msg] => Array ( [0] => Array ( [vers] => 9.2.1 [title] => Themes and Modules warning [desc] => Due some required changes in the core, all themes and a few modules also need to be updated. [url=http://dragonflycms.org/Forums/viewtopic/t=21393.html][color=red][b] Read me[/b][/color][/url] before you upgrade. [date] => 1202822853 ) ) ) [user] => Array ( [page] => News [file] => [uri] => /DHOTEST/public_html/index.php ) [gfx] => Array ( [887776] => 5e1c7a [774851] => 4853a6 [875783] => b13c1d [274808] => b39e87 [876982] => 262449 ) [comments] => Array ( [mode] => thread [order] => 0 [thold] => 0 ) [admin] => Array ( [page] => ) [session_start] => 1205379996 )

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1


That's not an error - that's just debugging info

Your Site wrote
Forbidden
You don't have permission to access /DHOTEST/public_html/images/blocks/CPG_Main_Menu/icon_home.gif on this server.


check your permissions on images folder

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1


actually, it might just be the images/blocks folder
images, images/news, images/icons all look ok.

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1


I am looking at the permissions and they all have read, write, and owner execute

I can't figure it out. Also the send to friend and printer friend icons in the news do not appear,....

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1


www.tmedweb.net/DHOTES.../print.gif

Same issue...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 24 / Apache 2.4.25 / MariaDB 10.0.23 / PHP 7.0.15 / Mercurial


I am actually loosing icons! I used to be able to see the FF icon at the bottom of the page and a few others in the admin menu

Im just going to fresh install with new SQl. Something is going very wrong.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1


Okay, fixed was a bad install to begin with... I'm seeing TONS more icons.

Guessing was a corrupt sql on install

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
5.0.45/5.2.5/9.2.1

All times are UTC


Jump to: