Support ⇒ Security ⇒ UUA Question ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexSecurity

UUA Question Reply to topic


Not sure if someone can post this in the forum, but maybe someone can at least PM me a response.

I am running DF 9.1.1 and I wanted to update it so that people using iphones and FireFox 3 stop getting the Uknown user Agent Ban.

I have searched through my sites DB and the files themselves and I can not seem to locate the file that has the list of acceptable UA strings. Searching the site here only leads me to some somewhat confusing posts that appear to only be in support of helping 9.2.1 + users.

So to put it simple. May I please get the info I need to update my site so that these newer browsers will have access?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37 (Unix)/4.1.22-standard-log/4.4.7/9.2.1


Look here. But basically you either have to use the code from 9.2.1 to amend the earlier version yourself, or - simpler - turn off User Agent checking in Administration > Security.

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


Thank you for your reply. I had actually found that topic earlier and the one it links to. I see that someone says they will release an update once a STSC? reads the rules.

I normally would have waited, but as this issue has been going on for several months, i had hoped to get some hints on how to correct it my self. I know the ua.inc is not in my version, but I can't find security.php either.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37 (Unix)/4.1.22-standard-log/4.4.7/9.2.1


So why not turn off User Agent checking?

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


I have turned it off, otherwise I wouldn't have waited several months to look into it : )

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37 (Unix)/4.1.22-standard-log/4.4.7/9.2.1


why not upgrade? (that theme is now updated Smile )

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1


O'Rly? Looks like I will be scheduling an upgrade, only reason was the theme. : )

Now to figure out how to do so without breaking things.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37 (Unix)/4.1.22-standard-log/4.4.7/9.2.1

All times are UTC


Jump to: