Languages and alternative language support ⇒ i18n - l10n (languages) ⇒ Funny language behaviour after upgrade ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Indexi18n - l10n (languages)

Funny language behaviour after upgrade Reply to topic


I just upgraded my 9.0.6.1 to 9.2.1 and since doing that my nordic characters has been PARTLY messed up...
For some reason even within the same module they sometimes show as they should, and sometimes they don't.

I've attached a screenshot showing how the members list looks right now. Characters also works in blocks like the user info block, and in forums it seems to work in what is the core files, but not in what is user posted, topics etc...

I tried updating the norwegian language pack thru Dragonfly Language Pack Management but got the error NO_CVS.
When trying to install a new norwegian language pack I got the error "Error creating important CVS files and folders"
I have tried this with the language folders chmoded to both 755 and 777

This site runs under
CMS Version 9.2.1
PHP Version 4.4.8
MySQL Version 5.0.22 (client: 3.23.49)

Does anybody have an idea what is going on here?
Attachment: norsk.jpg
Description
Filesize 24.61 KiB
Viewed 96 Time(s)
You are not allowed to view/download this attachment

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


Importing CVS files will only work if your system has a CVS client installed.

Get Notepad2, open a language file and make sure its UTF8 without signature or ANSI as UTF8 encoded. If you can see all chars correctly but its not correctly encoded then, and ONLY then:

start making a backup copy of the file
CTRL+A
CTRL+C
in Notepad2 select one of the previously mentioned encoding
CTRL+V
enjoy!

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


But i don't understand. The english language files are the ones that came with 9.2.1 and the same thing happens when switching to english language. If it was a language pack problem, then shouldn't this fix it? After all, Nordic characters posted by a user should show propperly when using a correct english language pack, right?

As it is now ALL user submitted text plus half of the core text when using norwegian language pack has this problem...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


In this case you need to update your WWW profile details or if you prefer sent me the URL in PM ... it may be possible its a server setup issue OR something else strictly related to your web site OR the browser you using.

Languages files are perfectly fine.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I did as you said and all language files are UTF8
Sent you PM with url to the site.

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


All corrupted content comes from the database ...

Try the second (2) solution

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


btw - Same trouble both in I.E and Safari browsers

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


Sorry. It didn't work
Characters still messed up. Hope I did it right now - see attached screenshot of config file
Attachment: norsk2.jpg
Description
Filesize 24.32 KiB
Viewed 100 Time(s)
You are not allowed to view/download this attachment

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


ok .. now if this was a new 9.1+ install put it back the way it was please.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I will try that. Installing everything over again, but I find it strange because all I have edited is the theme default. Same problems are still there when using the dragonfly themes. Nothing else has been edited.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


There!

Re uploaded everything including the theme files from original. Tried to install the cms again but got the messages that 9.2.1 was already installed on this server...

All other files uploaded from original 9.2.1 files but still the problem remains...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.4.28 - Linux srv60 2.6.12.6 / Apache / 4.0.22 - 4.1.22 - 5.0.22 -5.0.32 / 4.3.11 - 4.4.2 - 4.4.4 - 5.2.5 / 9.0.6.1 - 9.1.2.1 - 9.2.0.RC2


NanoCaiordo wrote
All corrupted content comes from the database


I think you installed when you had MySQL 4.0, then they upgraded to 5.0 but the config.php change should have fixed that ... I just can't see why this is happening .. but must be an easy solution lol (as usual)

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC


Jump to: