Miscellaneous ⇒ Server Chat ⇒ Zend Optimizer not installed ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexServer Chat

Zend Optimizer not installed Reply to topic


I noticed my error_log file, now 212Mb long was full of warnings about the Zend Optimizer. (PHP Warning: Zend Optimizer for PHP 5.2.x cannot be found (expected at '/usr/local/Zend/lib/Optimizer_TS-3.2.0/php-5.2.x/ZendOptimizer.so') - try reinstalling the Zend Optimizer in Unknown on line 0)

I uploaded a check php file to see if it was running and it returns:

Zend Optimizer Fail - Zend Optimizer Not Detected
Zend Optimizer must be Version 2.5.5 or greater! Ask your web host provider if you are unsure. The latest version of Zend Optimizer can be downloaded from www.zend.com.


My host suggested I upload their php.ini or add the following lines to my existing one:
; Directory in which the loadable extensions (modules) reside. extension_dir = "/usr/local/lib/php/extensions/no-debug-zts-20060613" zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so" zend_extension_ts="/usr/local/IonCube/ioncube_loader_lin_5.2_ts.so" [Zend] zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3 zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3 zend_optimizer.version=3.3.3 zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

I've tried that and it seems to work. What should I be doing - uploading their version?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


You could also disable the optimizer. Most of the times it slows down your server.

To do that add a ';' DOTCOMMA in front of the lines about the optimizer.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

All times are UTC


Jump to: