Support ⇒ New installations ⇒ [solved] problem with default htacces file and my host ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

[solved] problem with default htacces file and my host Reply to topic


I just did get me a new host for a dragonfly site i wanted to setup.
But i run into problems because of the default .htacces file thats included.
I now see there restrictions for htacces files with my host.. but its too late to change, i just ordered and payed and then found out when i finished upping/chmodding and wanted to use install script.

The error from my log:

[Mon Oct 12 19:28:13 2009] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Mon Oct 12 19:28:13 2009] [alert] [client 84.xx.xxx.xxx] /home/deletedmydomainhere.com/www/.htaccess: IndexIgnore not allowed here

I dont want to change host.. because then i would have paid for a full year hosting for nothing.
Can i edit/change the default .htacces file from dragonfly so it works for me?

I have no experience with htacces files.. used df before but back then had different host and no problems.
Could someone give me instructions what i need to alter so i can continue?

And if i do that.. will it make my df site less secure or other side effects?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian / Apache 2 / MySQL 5.0.84 / PHP 5.2.9 / Dragonfly CMS 9.2.1.0


Oh i used entered the warn in search and in the topic i found it said: Apache 2 doesn't support NoCase for REQUEST_FILENAME -f.
Simply change [NC,OR] to [OR] at line 55.

So i removed NC.. but i still have the same problem.

Current site:
EQdkp-Plus 0.6.3.5, PHPBB3 3.0.6, PHP 5.2.9, MySQL 5.0.84 , Apache 2
Visit us: www.lessqqmorepewpew.eu

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian / Apache 2 / MySQL 5.0.84 / PHP 5.2.9 / Dragonfly CMS 9.2.1.0


I temporary removed the entire .htacces file so i could continue with the installation and start setup my df.

Except from being banned with the first click after install (unknown user agent and had to upload latest ua.inc) no problems.

I hope someone can help me out here fixing the .htacces so it works for me, i'll keep the site running in maintenance mode for now and only me know it exists i hope ^^

Current site:
EQdkp-Plus 0.6.3.5, PHPBB3 3.0.6, PHP 5.2.9, MySQL 5.0.84 , Apache 2
Visit us: www.lessqqmorepewpew.eu

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian / Apache 2 / MySQL 5.0.84 / PHP 5.2.9 / Dragonfly CMS 9.2.1.0


Cybermonk wrote
[Mon Oct 12 19:28:13 2009] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

dragonflycms.org/cvs/html/.htaccess
Fixed in revision 9.20 (2008/11/29)

Cybermonk wrote
[Mon Oct 12 19:28:13 2009] [alert] [client 84.xx.xxx.xxx] /home/deletedmydomainhere.com/www/.htaccess: IndexIgnore not allowed here

.htaccess line 79 wrote
# disallow index viewing (like ftp) of directory
# Remove # for production sites
# Options -Indexes

# for hosts that don't allow the above, we won't give people anything to look at
<IfModule mod_autoindex.c>
IndexIgnore *
</IfModule>


Just put a # in front of 'IndexIgnore' and remove the # in front of 'Options -Indexes'

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


I downloaded that .htacces file.. and also changed what u said.. but still i get that error 500

Log:

[Tue Oct 13 03:39:44 2009] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Tue Oct 13 03:39:44 2009] [alert] [client 84.25.215.156] /home/lessqqmorepewpew.eu/www/cms/.htaccess: Options not allowed here

.htacces:

# disallow index viewing (like ftp) of directory
# Remove # for production sites
Options -Indexes

# for hosts that don't allow the above, we won't give people anything to look at
<IfModule mod_autoindex.c>
# IndexIgnore *
</IfModule>

I also tried putting a # before Options -Indexes again.. but i still get that error options not allowed here.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian / Apache 2 / MySQL 5.0.84 / PHP 5.2.9 / Dragonfly CMS 9.2.1.0


Eh ignore last post please.
Its late and im tired.. and i didnt notice i was editting .htacces file in wrong directory :s
Thank you for this instructions, worked fine Very Happy

Current site:
EQdkp-Plus 0.6.3.5, PHPBB3 3.0.6, PHP 5.2.9, MySQL 5.0.84 , Apache 2
Visit us: www.lessqqmorepewpew.eu

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian / Apache 2 / MySQL 5.0.84 / PHP 5.2.9 / Dragonfly CMS 9.2.1.0

All times are UTC


Jump to: