Support ⇒ Themes ⇒ Add download blank ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexThemes

Add download blank Reply to topic


I've suddenly got a problem with my Add Download page. All used to work fine but, with me changing nothing (I think) the page now serves up the path at the top but no fields. This is with the reDesign theme. In default theme it displays fine.

Where should I be looking for a solution?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


While it sounds like a theme problem, I can't see any code in reDesign specifically for Downloads let alone Downloads Pro.

The module that would be current then would be /modules/Downloads/add.php. Which is presumably getting executed fine up until at least the require_once('header.php') line.

But if you are on 9.3.x I can't help too much further. (Displays ok on 3 of my sites, on both my latest reDesign3+ and original reDesign3_CVS, but all under 9.2.1.)

Start adding echo statements after the page header? Does it display when you are logged in as Admin too? Or Admin only? No SQL or PHP errors or warnings I take it?

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


No errors or warnings. Same SQL statement is run with both themes. Same result logged in as admin or not.

I added in a couple of echo statements and it seems the file is running ok. It is just assigning any variables to the template that display. Which template file would I check?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


rosbif wrote
Which template file would I check?


That's the point, there isn't any reDesign templates for Downloads - either version. So you should - I think - be seeing a debug message like:

includes/classes/template.php
CMS Notice line 121: template->_tpl_load(): themes/{your_theme_name_here}/template/downloads/manage.html doesn't exist

when it switches to the correct (original) Downloads Pro template in the default theme.

You haven't loaded the original CPG Downloads templates (ie the non-Downloads Pro ones) into your current theme have you, by any chance? Then it would try to use those, and IIRC, Downloads (non-Pro) doesn't support Add Download for users like D Pro does.

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


Well I've just renamed my exisiting reDesign/templates/downloads folder to xdownloads and it now displays fine. I've also just reuploaded the latest templates/downloads folder from a fresh zip of Downloads Pro and it is still working fine. So something must have been wrong with one of my template files.

But, problem solved for now - I'll try and compare the two and see where the error was...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):

All times are UTC


Jump to: