Support ⇒ Troubleshootings ⇒ LEO, only SOME links working ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

LEO, only SOME links working Reply to topic


My .htaccess:

# CPG Dragonfly CMS # Copyright (c) 2004-2006 by CPG-Nuke Dev Team, dragonflycms.org # Released under the GNU GPL version 2 or any later version # Remove the pound sign on these 3 for production sites # if your server doesn't allow it then a Error 500 is given # php_flag display_errors off # php_value error_reporting 0 # php_flag register_globals 0 # flood protection # deny most common except .php <FilesMatch "\.(inc|tpl|h|ihtml|sql|ini|conf|bin|spd|theme|module)$"> deny from all </FilesMatch> # disable access to config.php and .ht* from a browser <FilesMatch "^(config\.php|\.ht)"> Deny from all </FilesMatch> <FilesMatch "error\.(php|gif)"> allow from all </FilesMatch> # if you use LEO, mod_rewrite is necessary <IfModule mod_rewrite.c> RewriteEngine On # Check for Santy Worms and redirect them to a fail page #------------------------------------------------------------------- # Variant -1 # uncomment if you dont use LWP # RewriteCond %{HTTP_USER_AGENT} ^LWP [NC,OR] RewriteCond %{HTTP_USER_AGENT} Baidu [NC,OR] # Variant -2 RewriteCond %{REQUEST_URI} ^visualcoders [NC,OR] # Variant -3 RewriteCond %{QUERY_STRING} rush=([^&]+) [NC,OR] # Variant -4 RewriteCond %{HTTP:x-moz} ^prefetch [NC,OR] RewriteCond %{X-moz} ^prefetch [NC,OR] # block local file, sql and remote attacks RewriteCond %{QUERY_STRING} \=../ [NC,OR] RewriteCond %{QUERY_STRING} "%20UNION" [NC,OR] RewriteCond %{QUERY_STRING} \=http:// [NC] # deny them RewriteRule ^.*$ - [F] #------------------------------------------------------------------- RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.*)$ - [L] # if you use LEO and CPG-Nuke is installed in a sub-directory like '/html', # remove that # before RewriteBase and rename /html to the path of the sub-directory RewriteBase / # RewriteRule ^index\.html /index.php RewriteRule ^([a-zA-Z0-9_=+-]+)(/|\.html)$ index=$1 [L,S=5] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)(/|\.html)$ index=$1&file=$2 [L,S=4] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)$ index=$1&file=$2 [L,S=3] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=$2&$3 [L,S=1] RewriteRule ^([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=index&$2 [L] RewriteRule ^index=(.*[^/])/(.*) index=$1&$2 [N,L] RewriteRule ^index=(.*) index.php?name=$1 [L] </IfModule> # use custom error pages if you wish ErrorDocument 400 /error.php ErrorDocument 401 /error.php ErrorDocument 403 /error.php ErrorDocument 404 /error.php ErrorDocument 500 /error.php # disallow index viewing (like ftp) of directory # Remove # for production sites # Options -Indexes # for hosts that don't allow the above, we won't give people anything to look at <IfModule mod_autoindex.c> IndexIgnore * </IfModule> AddDefaultCharset utf-8

Some of the URLs work, some give 404 errors. It's a fresh installation, nothing was changed except some forums added. Example of some non-working URLs:
http://site.com/Your_Account/profile=Admin.html http://site.com/News/topic=1.html http://site.com/Your_Account/edit=reg_details.html http://site.com/Your_Account/edit=avatar.html http://site.com/Private_Messages/mode=post.html http://site.com/Forums/posting/mode=editpost/p=1.html http://site.com/Forums/posting/mode=quote/p=1.html
examples of WORKING URLs:
http://site.com/Private_Messages.html http://site.com/Forums/viewtopic/t=1.html http://site.com/News/article/sid=2.html http://site.com/Forums/archives.html

I use x10hosting.com
mod_rewrite works and Apache

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 8 / Apache: 2.2.24 / MySQL: 5.1.71 / PHP: 5.4.17 / Dragonfly: LATEST VERSION


You didn't provide enough information to investigate why it doesn't work.
We ask server specs and domain name, none is given.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


DJ Maze wrote
You didn't provide enough information to investigate why it doesn't work.
We ask server specs and domain name, none is given.


Sorry about that. Thanks for your reply.

Domain: forums.x10.mx
I am using x10hosting.com, mod_rewrite is enabled / apache working.

Thanks.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 8 / Apache: 2.2.24 / MySQL: 5.1.71 / PHP: 5.4.17 / Dragonfly: LATEST VERSION


Go into My Profile Information on this site and complete:

Home Page (= your website address)

OS/Apache/MySQL/PHP/DragonflyCMS versions

Then we might understand enough to help.

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


Done..
Windows 8 / Apache: 2.2.24 / MySQL: 5.1.71 / PHP: 5.4.17 / Dragonfly: Latest Version

Here is a link to my site: x.co/3dkfD
I have no clue why only some of the rewrites work, and others don't.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 8 / Apache: 2.2.24 / MySQL: 5.1.71 / PHP: 5.4.17 / Dragonfly: LATEST VERSION


As reported here: www.ravenphpscripts.co...1184-.html
It seems to be LiteSpeed, not Apache.
LiteSpeed claims full mod_rewrite compatibility but it seems it doesn't.

Try:
# CPG Dragonfly CMS # Copyright (c) 2004-2006 by CPG-Nuke Dev Team, dragonflycms.org # Released under the GNU GPL version 2 or any later version # Remove the pound sign on these 3 for production sites # if your server doesn't allow it then a Error 500 is given # php_flag display_errors off # php_value error_reporting 0 # php_flag register_globals 0 # flood protection # deny most common except .php <FilesMatch "\.(inc|tpl|h|ihtml|sql|ini|conf|bin|spd|theme|module)$"> deny from all </FilesMatch> # disable access to config.php and .ht* from a browser <FilesMatch "^(config\.php|\.ht)"> Deny from all </FilesMatch> <FilesMatch "error\.(php|gif)"> allow from all </FilesMatch> # if you use LEO, mod_rewrite is necessary <IfModule mod_rewrite.c> RewriteEngine On # Check for Santy Worms and redirect them to a fail page #------------------------------------------------------------------- # Variant -1 # uncomment if you dont use LWP # RewriteCond %{HTTP_USER_AGENT} ^LWP [NC,OR] RewriteCond %{HTTP_USER_AGENT} Baidu [NC,OR] # Variant -2 RewriteCond %{REQUEST_URI} ^visualcoders [NC,OR] # Variant -3 RewriteCond %{QUERY_STRING} rush=([^&]+) [NC,OR] # Variant -4 RewriteCond %{HTTP:x-moz} ^prefetch [NC,OR] RewriteCond %{X-moz} ^prefetch [NC,OR] # block local file, sql and remote attacks RewriteCond %{QUERY_STRING} \=../ [NC,OR] RewriteCond %{QUERY_STRING} "%20UNION" [NC,OR] RewriteCond %{QUERY_STRING} \=http:// [NC] # deny them RewriteRule ^.*$ - [F] #------------------------------------------------------------------- RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.*)$ - [L] # if you use LEO and CPG-Nuke is installed in a sub-directory like '/html', # remove that # before RewriteBase and rename /html to the path of the sub-directory RewriteBase / # RewriteRule ^index\.html /index.php RewriteRule ^([a-zA-Z0-9_=+-]+)(/|\.html)$ index=$1 [S=5] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)(/|\.html)$ index=$1&file=$2 [S=4] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)$ index=$1&file=$2 [S=3] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=$2&$3 [S=1] RewriteRule ^([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=index&$2 RewriteRule ^index=(.*[^/])/(.*) index=$1&$2 [N] RewriteRule ^index=(.*) index.php?name=$1 [L] </IfModule> # use custom error pages if you wish ErrorDocument 400 /error.php ErrorDocument 401 /error.php ErrorDocument 403 /error.php ErrorDocument 404 /error.php ErrorDocument 500 /error.php # disallow index viewing (like ftp) of directory # Remove # for production sites # Options -Indexes # for hosts that don't allow the above, we won't give people anything to look at <IfModule mod_autoindex.c> IndexIgnore * </IfModule> AddDefaultCharset utf-8

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


DJ Maze wrote
As reported here: www.ravenphpscripts.co...1184-.html
It seems to be LiteSpeed, not Apache.
LiteSpeed claims full mod_rewrite compatibility but it seems it doesn't.


Wow, that works perfectly..
Thank you, DJ Maze, for the awesome support and developing a great CMS.
Smile

One question, would it be too much work renaming the Your_Account module to simply "Account" so that the URLs would look like "/Account/op=register.html" instead? Or is there a lot of core editing to do that?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 8 / Apache: 2.2.24 / MySQL: 5.1.71 / PHP: 5.4.17 / Dragonfly: LATEST VERSION

All times are UTC


Jump to: