Support ⇒ Upgrades ⇒ Upgrade 9.3.4.1 to 9.4.0.0 - now no admin ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

Upgrade 9.3.4.1 to 9.4.0.0 - now no admin Reply to topic


I've just updated one of my sites from 9.3.4.1 to 9.4.0.0 and I now cannot access admin.php (or any other admin pages). On chrome where I am logged in as admin already after about 3-4 minutes of waiting for admin.php this is the error:

On /admin.php
While executing query "SELECT g.group_id, g.group_name, g.group_single_user FROM cms_bbgroups AS g INNER JOIN cms_bbuser_group AS ug ON (ug.group_id=g.group_id AND ug.user_id=2 AND ug.user_pending=0)"

the following error occured: MySQL server has gone away

In: /home/stpeter2/public_html/includes/classes/cpg_member.php on line: 84


On IE where I am not logged in as admin I get the page loaded and type in my username and password (it recognises if I get it wrong) it then gives me this 500 error after 4-5 minutes:

Premature end of script headers

The URL that you requested, /admin.php, resulted in a server configuration error. It is possible that the condition causing the problem will be gone by the time you finish reading this.

We have logged this error and will correct the problem.


There is nothing in error_log. Any ideas?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


This is solved.
I activated https on our server, but that kills admin.php on any Df website that connects with ours for fetching update info.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Tue Dec 01, 2015 8:22 am; edited 1 time in total


DJ Maze wrote
This is solved.

Just sitting down to debug ... Glad I checked here.

BTW on mine I got a slew of MySQL server has gone away messages citing my IP address when I failed to login as admin. Tied up the MySql connection until Host timed it out perhaps?

DJ Maze wrote
... on any Df website that connects with ours for fetching update info.

There is a way to turn the update check off on our sites? Where would that be please?

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


layingback wrote

DJ Maze wrote
... on any Df website that connects with ours for fetching update info.

There is a way to turn the update check off on our sites? Where would that be please?


Settings...System....Enable Update Service Off

Thank goodness that wasn't my upgrade! Sod's law I was working on it the day you did that here!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Thanks, rosbif.

I looked there .. but didn't see it! Laughing

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


DJ Maze wrote
This is solved.
I activated https on our server, but that kills admin.php on any Df website that connects with ours for fetching update info.


Missing HTTP -> HTTPS redirect causing this?

Marco

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC


Jump to: