Miscellaneous ⇒ Search Engines ⇒ My website only works with Firefox ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexSearch Engines

My website only works with Firefox Reply to topic


When I use Crome or Internet Explorer to view my site it displays funny charactors.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP/Apache 1.3.33(Win32)/MySQL 4.1.9/PHP 4.3.10/CPGNuke ?Dragonfly 9.0.6.1


I don't see funny characters on de the Brisbane Jeep Club.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


That one is not mine any more. Mine is Justrealjeeps.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP/Apache 1.3.33(Win32)/MySQL 4.1.9/PHP 4.3.10/CPGNuke ?Dragonfly 9.0.6.1


could be double gzip encoding.
Try editing ./includes/cmsinit.inc line 24
define('GZIPSUPPORT', extension_loaded('zlib'));in
define('GZIPSUPPORT', false);

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Ok havent had time to look at it yet. So is this something that everybody else has had to do or is this related to the host server.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP/Apache 1.3.33(Win32)/MySQL 4.1.9/PHP 4.3.10/CPGNuke ?Dragonfly 9.0.6.1


It's something with the host server.
GZIP compression can be done at PHP level or at HTTPD (nginx, apache, etc.).
When both are turned on, the content is encoded twice.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

All times are UTC


Jump to: