Support ⇒ Troubleshootings ⇒ error log full of Unable to load dynamic library errors ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

error log full of Unable to load dynamic library errors Reply to topic


My error log is filling with the following error since my host upgraded php. What's the easy way to stop it?

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/yaml.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/yaml.so: cannot open shared object file: No such file or directory in Unknown on line 0

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Your host must fix this.
The only thing you can do is report this to your host or change hosting provider.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Fri Oct 13, 2017 2:59 pm; edited 1 time in total


Host says they can disable error logging and that's it. They say

Basically means that the yaml php extension cannot be loaded but that extension has been deprecated since PHP5.4.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Huh?!? Yaml is NOT deprecated. It is a stable PECL extension, even for PHP7.

It's just as simple as to edit /etc/php.d/40-yaml.ini
;extension=yaml.so

What a terrible paragon.net.uk employee you encountered.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

Last edited by DJ Maze on Fri Oct 13, 2017 11:46 pm; edited 3 times in total

All times are UTC


Jump to: