Support ⇒ Dragonfly CMS v10 ⇒ URL without index.php ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexDragonfly CMS v10

URL without index.php Reply to topic


Hi,

Recently I update an old domain from 9.2 to v10 and I have a big problem with google indexation.

All links has been changed and index.php desapper from url. How can I revert changes and add again index.php to url generation?

Thanks,

until the next (Bye),

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.2 (PHP5.4)


Disable LEO in Admin -> Settings

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


It doesn't matter. I have it disabled but index.php doesn't appear

until the next (Bye),

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.2 (PHP5.4)


After check the code I use some days the web, I see some errors:

1. If I don't use leo, by default all url are without index.php. I change code to add this text into 2 lines:
- Line 41: $url = 'index.php?name=' .$url; INSTEAD $url = '?name=' .$url;
- Line 44: $url = 'index.php'; INSTEAD $url = '';

2. I see that function includes/classes/url.php -> index(), creates urls to web but when we are without https don't set conexión scheme and all urls are "incorrect": //dragonflycms.org/. If I try to set $scheme at the begining to 'http' instead of '' the result is quite good but I found some problems like some links are http instead of https when navigate from secure one.

There are some posible soluctions?

until the next (Bye),

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly 9.2 (PHP5.4)

All times are UTC


Jump to: