Support ⇒ Dragonfly CMS v10 ⇒ Gibberish Displayed During V9.4 to V10 Upgrade ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexDragonfly CMS v10

Gibberish Displayed During V9.4 to V10 Upgrade Reply to topic


So I copied all V10 Files to my Current V9.4 installation.
Updated "Config.php" in "include" Directory
Updated .htaccess

Executed the installer
mydomain.com/?install

This is a sample of what was displayed, a full view I have attached in a screenshot, Nothing I can see in error logs either.

"����r�HvƯ���eU2vE�,O6��e�h����%-I��J�$!k`в���E��py����� (��T�fF�t�?�9��� �����t��j���z�&9�?"
Attachment: Dragonfly.gif
Description
Filesize 230.32 KiB
Viewed 0 Time(s)
You are not allowed to view/download this attachment

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4


Probably your text editor is set to add Unicode BOM, make sure it's encoding is UTF8 without BOM.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


The only files I edited were the Config.php and .htaccess
Both of which I replaced and verified that they were encoded with UTF8 without BOM

I Did find the following error in Cache/error208-w51.log

PHP Notice includes/dragonfly/config/config.php line 174: Undefined index: log_level
PHP Notice includes/dragonfly/config/config.php line 174

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Wed Dec 19, 2018 8:48 pm; edited 1 time in total


I re-downloaded the Package and attempted to setup a clean site (Not an Upgrade)
however I still get the same result.

I also attempted to use the Phar Installer and it was returned with "Can't reach this page" in IE
and in Chrome it came back with "redirected too many times" " ERR_TOO_MANY_REDIRECTS"


Any help would be appreciated

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Thu Dec 20, 2018 3:49 am; edited 2 times in total


It could be double gzip encoding.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Double GZip Encoding? How is this occurring?

Not sure if it helps but here is a link to my PHP Info

df.deathinc.net/phpinfo.php

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Thu Dec 20, 2018 9:31 pm; edited 1 time in total


What is this needed for "REDIRECT_HANDLER x-mapp-php5.5"

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I am not exactly sure what "REDIRECT_HANDLER" x-mapp-php5.5 is for, This is a shared hosting server, So I have limited control over what is set in the php.ini by default. Whatever I can change, were php is concerned, has to either be in a .htaccess or a .user.ini file.

I was having no issue prior to atempting to upgrade my DF 9.4 site to V10.
As i previoulsy stated I also tried doing a clean setup of V10, with the same results.
Using the PHAR and Full Package Install options.
I have tried different PHP Versions 5.6, 7.1, 7.2 all with the same results.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Sat Dec 22, 2018 11:02 am; edited 1 time in total


Hope everyone had a good holiday !

Did anyone have any thoughts or Ideas on this issue ?


Thanks.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Wed Dec 26, 2018 9:40 pm; edited 1 time in total


Hello, yes holidays were great, I hope you had good one too!

Your phpinfo response headers do show gzip encoding and it seems apache's rewrite module isn't enabled.
By enabling the rewrite module within apache, our .htaccess can then turn default compression off.

Cheers

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

Last edited by NanoCaiordo on Fri Dec 28, 2018 5:08 am; edited 1 time in total


I just checked, It is on.

df.deathinc.net/test/phpinfo.php

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4

Last edited by Demetrios on Fri Dec 28, 2018 4:32 pm; edited 1 time in total


Yeap, try to turn it off.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


So I have tried the following with no luck:

RewriteRule ^(.*)$ $1 [NS,E=no-gzip:1,E=dont-vary:1]

SetEnv no-gzip 1

php_flag zlib.output_compression off



Kind of at a loss at this point.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/ MySQL 5.5/PHP 5.6 - 7.2/DragonflyCMS 9.4


It seems the mod_rewrite module it's not loaded in Apache configuration, got to load it first, then remove your RewriteRule to let DragonflyCMS rules kick in.

So, ask your sysadmin if the mod_rewrite module is loaded, if not, ask him to enabled it.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC


Jump to: