Support ⇒ Dragonfly CMS v10 ⇒ DF .htaccess is breaking apache ultimate bad bot blocker? ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexDragonfly CMS v10

DF .htaccess is breaking apache ultimate bad bot blocker? Reply to topic


I'm trying to use apache ultimate bad bot blocker:
github.com/mitchellkro...ot-blocker

However something in our .htaccess file is overriding it, and the tests fail to block anything.
If I rename .htaccess, it works as it should.

But I can't see anything in .htaccess that overrides a "Require" setting.
What else in .htaccess might affect this? Could the re-writes do it? I wouldn't have thought so...

# curl -A "80legs" -I https://www.mustangtech.com.au HTTP/1.1 200 OK # mv .htaccess .htaccess-old # curl -A "80legs" -I https://www.mustangtech.com.au HTTP/1.1 403 Forbidden # curl -A "googlebot" -I https://www.mustangtech.com.au HTTP/1.1 200 OK

Any ideas?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


A copy of your htaccess would help for sure, but which bad bot blocker are you running 2.2>2.4 *(requires mod_access_compat) or 2.4 only.

If you have privacy concerns with sharing htaccess, make an archive and private message me the URL.

*Edit: add requirement

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

Last edited by NanoCaiordo on Sun Jun 30, 2019 12:16 pm; edited 1 time in total


I'm using 2.4 version.
The htaccess should be the one straight from df 10. I have not modified it.

I'm including botblocker in the main Apache config to cover all sites.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Which steps, 1-6, have you done from this page: github.com/mitchellkro...Apache_2.4

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

Last edited by NanoCaiordo on Sun Jun 30, 2019 10:05 pm; edited 1 time in total


I have included the blacklist config globally, so the second option in Step 6.
The other two websites I host are working fine. Only DF doesn't work.

But it works fine if I don't use the DF .htaccess.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


globalblacklist.conf includes at least other 3 configs... try to remove the <IfModule mod_setenvif.c> block from df .htaccess

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Remove the whole section, or just the <IfModule> tags?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Removing the whole section seems to have fixed it, thanks.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


You're welcome Smile

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

Last edited by NanoCaiordo on Sun Jun 30, 2019 11:49 pm; edited 1 time in total

All times are UTC


Jump to: