Miscellaneous ⇒ Licenses, GPL & Violations :: Archives ⇒ MySQL license and hosts having trouble with :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexLicenses, GPL & Violations

Archived ⇒ MySQL license and hosts having trouble with


Today i noticed some webhosts don't upgrade because they say they have a license issue with the MySQL server.
In other words: "Our linux system doesn't use a OpenSource license that is approved by the OSI"
Strange since i think all Linux are OSS unless they buy Redhat Enterprise or something.

But if they think they are in violation then even with MySQL 3 they are already in violation UNLESS they use a version prior to 3.23.19 (june 11, 2000) Read here

If a product is commercial and it uses MySQL, like Burnwave's Shop, Invision Power Board or Windows OS Servers, the MySQL server has to be bought.

More info about MySQL licensing can be found here:
www.mysql.com/company/...cense.html

You can order MySQL for $250 or $500 here:
order.mysql.com/?sub=pg&pg_no=1

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


one of my hosts wont upgrade for that very reason. MySQL 3x does not require the license. Also Enterprise Red Hat 3, and the enterprise "read commercial" versions like RHE3 and SUSE have nothing more than MySQL 3.x bundled.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OSX / Apache 2 / MySQL 4 / PHP 4


my partner make a update i think

but i am not shure because of this line:(pinfo)

SQL Server

Quick Stats:
Server Version: 4.0.21-standard
Client Version: 3.23.58


with this dragonflycms.de works

.: USE THE FORCE :.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


ravenphpscripts.com/po...html#32921

Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux


Have a grumpy hosting service? You might want to consider changing. I dumped my old hosting service in favor of my current one becuase their answer to my query on upgrading was to pay for a private server with them instead of the shared plan.

My answer was... "See ya!" And I have been happy with that choice ever since.

- |\\/|ystic

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu 14.04.1/Apache 2/5.5.38/5.5.9/9.4.0.0

All times are UTC