Support ⇒ CPG-BB (forum) :: Archives ⇒ synchronize attachments :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Modules & Blocks CPG-BB (forum) ⇒ Archives

Archived ⇒ synchronize attachments


I have successfully transferred the data from my phpBB board over to CPG-nuke 9.0.5.0, however not all the attachments are being displayed on the forum for some reason. I attempted to synchronise the attachments, but the page continuously timed out when I attempted to synchronize the attachments.
I manually went to the url I assume is the correct location for the page to synchronize attachments www.mysite.com/dragonf...ttachments when I did this however I received the error CMS Error /home/lakepir/public_html/dragonfly/includes/classes/template.php line 124: template->_tpl_load(): No file specified for handle body.
Have I got the wrong url? Or is there something wrong with this file?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


Which theme are you using?

DonationsPro for DragonflyCMS & SMF

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


I have tried with both themes that come with cpgnuke 9.0.5, the cpgnuke and dragonfly themes.

{SIG REMOVED - PLEASE REDUCE TO REGULATION SIZE}

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


I feel like maybe I should offer more information and clarifiction about my situation. I am really looking forward to using cpg-nuke, however I need to have the attachments working correctly before I can swap over to cpg-nuke.
The only modification I have made to the default installation is to change the settings to how I want them through the administration section, I have not modified any files however. I have installed the Charcoal 3 theme since, but I am unable to synchronize attachments in either the charcoal theme or the two default themes which are packaged with cpg-nuke 9.0.5.0.
I downloaded cpg-nuke 9.0.5.0 from this website, and have extended the timeout period for my browser so this should not be a problem. I have synchronized the attachments on my phpbb forum, and it only took 10 seconds to do. The attachments CP is showing the correct number of attachments, filesize on disk, posts with attachments etc, so the attachments data appears to have transferred correctly.
A couple of posts have the attachments shown in them, but the majority of posts are showing up as having no attachments. This is why I have attempted to synchronize the attachments.
I used the phpbb to cpg-nuke converter downloaded from this website to transfer the data over. All the posts have been successfully transferred, and I manually activated all users.
The error I get when attempting to synchronise attachments is:
While trying to retrieve the URL: [url=http://www.lakepirateforums.com/dragonfly/[no Url]][no URL][/url]

The following error was encountered:

* Read Timeout

The system returned:

[No Error]

I have tried in both internet explorer and firefox. All other functions of the forum and the forum admin section appear to be functioning without any problems.

If there is anymore information you need to be able to help me with this problem I will of course provide them Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


I believe that the reason for my trouble synchronising attachments as mentioned in this thread: http://www.cpgnuke.com/Forums/viewtopic/t=11969.html
is that the attachment mod behaves strangely when Gzip compression is enabled. So I would like to know why the option to disable Gzip compression has been disabled in cpgBB.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


Gzip has nothing todo with it, it's related to set_time_limit

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


I have changed the max_execution_time to 700 as well as the my browser connection and request timeouts in firefox. I still experience the same problem when I do this however, yet with phpBB and phpnuke with attachment mod installed, I am able to synchronize the attachments in less then 20 seconds.
If I am doing anything wrong with extending the execution time please let me know.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


I am able to synchronize attachments on this very server using phpBB with attachment mod, and phpnuke with the attachment mod. All php settings are the default for my host with phpBB and phpnuke, the only difference in settings as far as I can tell is that cpg nuke has gzip enabled and the attachment mod has issues with gzip compression(found this out from the creators website opentools.de)
This is why I believe that it is a problem with Gzip and not the script timing out.

{SIG REMOVED - PLEASE REDUCE TO REGULATION SIZE}

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


phpnuke + phpBB ≠ dragonfly

NEMINI.org, NEMINI.us, NEMINI.info, NYMINI.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
1.3.34 (Unix)/4.1.18-standard/4.4.2 /9.1.0.8 CVS


merged to correct forum

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


I see the issue, it's not gzip related but it's OB-handler related.
I've tried to fix it for ya see dragonflycms.org/cvs/h...hments.php

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Thank you very much for your help DJMaze. It is greatly appreciated Very Happy
The new admin_attachments.php successfully synchronised the attachments for me, I still didnt get the confirmation page but that might be due to a timeout issue with going through my ISPs proxy server. I will have somebody test it for me as soon as I can and let you know.
As long as the attachments are synchronized I am happy Smile

{SIG REMOVED - PLEASE REDUCE TO REGULATION SIZE}

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.1.13-standard/4.3.11/9.0.6.1


How did you do sync the attchemetns? I am tring to convert from phpbb to DF but I can not find a way to sync the attachements. I have all the posts synced but none of the attachement data was synced.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS/1.3.34/4.0.25/4.4.1/9.0.6.1


He grabbed the file admin_attachments.php that dj linked to, uploaded it to admin/modules/forums replacing his old admin_attachments.php and then synchronized.

Diagon Alley - Top Design

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1

All times are UTC