Support ⇒ Troubleshootings :: Archives ⇒ Moving Site to a different domain... :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

Archived ⇒ Moving Site to a different domain...

Go to page 1, 2, 3 Next

To start off with I did do a few searches and didn't come across anything that would help me solve this problem.

The problem is that I am moving a complete installation of Dragonfly to a new domain for a client. The original domian was being used as a "setup domain" and now since his boss approved the site it needs to be moved to it's permanent domain.
So, I backed up the database and backed up all the files. Then I tried to just upload the files to the new domain, recreated the database, adjust settings in the config file...thinking that would do it and I would be ready to go.

Except I have 1 big problem. On the new site the basic cpg-nuke theme (that has been modified and is required for the site) can't seem to find ANY of the images for the theme( they all show up as the boxes with the X in them).

Now I scanned through the database and changed all references from the old domain to the new domain and that didn't help either. I installed from scratch and then redid the database with the on I have backed up and re-uploaded the files and that didn't work either.

What could I be missing??

The site I am moving to is located at www.pdmaontario.ca/ and that shows the issue at hand.

P.S. Since none of the graphics seem to work I also can not login as an ADMIN... (I have the graphix code turned on for admin login.)

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


images are looking in www.pdmaontario.ca/PDMA/

looks like your installation is in www.pdmaontario.ca

I suggest you update your path in the config custom table. ( should be / )

NEMINI.org, NEMINI.us, NEMINI.info, NYMINI.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
1.3.34 (Unix)/4.1.18-standard/4.4.2 /9.1.0.8 CVS


updated and same problem.....

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


It looks like after you moved over and changed the setting from /PDMA/ you theme still think that you still default to that directory. I did a test run on my test server and it did the same thhing. I tried to clear the cache and delete the temp IE files and it still doing it. Try clearing your cache thou to see if it work.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


I deleted chache/history on IE with no result...

It has to be something somewhere else in the database.

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


This is what you need to do, but it will require a lot of moving files at your part.

1st Create a directory /PDMA/ under www.pdmaontario.ca,
2nd Copy or upload a 2nd copy of the files to that directory.
3rd Login to your admin account through www.pdmaontario.ca/PDMA/admin.php and go to the main setting to site path to /.
4th Delete the /PDMA/ directory it should fix the problem.

I just tried that on my test server and it work

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


Also, make sure you have cleared your cache folder of any files.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win, Linux/1.3.34/4.0.26, 5.0.19/4.3.10, 5.1.2, 8.1.4(PostgresSQL)/9.0.6.1, CVS


clear the cache on the server

NEMINI.org, NEMINI.us, NEMINI.info, NYMINI.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
1.3.34 (Unix)/4.1.18-standard/4.4.2 /9.1.0.8 CVS


No I can't login as an admin....in place of the security code it says "please accept cookies" and I even tried as a normal user and it wouldn;t let me because it thinks my cookies are blocked. I double-checked everything and cookies are not blocked.

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


Log in to the database and turn off security code for now and try.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


Even the regular login without the security code does not work...it takes me to an error page saying cookies are not enabled...

And in the database setting I was changing the setting for sec. code around and it did not have any effect on the sec. code going away. But if the whole site thinks cookes are blocked it wont matter if the sec. code is there...

I am starting to get very confused.....

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


True, it wont matter if that server is on a lock down. It will not let you log in. Try deleting your cookies setting on your browser. Also

NEMINI wrote
clear the cache on the server


And see if it will let you in.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


I did all that ahead of time....

And the server itself is not on lockdown.....

Joel
Tri-State Computer Consulting
jsellnau @ tsccgraphix.com
www.tsccgraphix.com
ww.tri-stateconsulting.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CentOS 3.4/Apache 1.3.34/mySQL 4.0.25/PHP 4.4.1/DF 9.0.6.1


I am having the same problem on my test server. Looking into it also.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


OK This is what I did, I had exported the whole Database. And Drop the one on the server, recreated a new database. And run the SQL to reload the database. And my test site is back to normal.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1

All times are UTC
Go to page 1, 2, 3 Next