Support ⇒ New installations :: Archives ⇒ 9.01 gmt error :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

Archived ⇒ 9.01 gmt error


Hi,
i have downloaded Dragonfly 9.01 and i have upgrade my previous installation.
All works fine except the gmt that now is set to -12 hours.
i have tried to change timezone in cms_users and cms_users_temp table setting it to +1 but nothing is changing. (My Forum config is +1).
What i shall do?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian 4.0 / --- / MySql 5.0.32-Debian_7etch6 / PHP 5.2.0-8+etch11 / 9.2.1


I have solved my problem setting in database +1 gtm as default and hiding "timezone" during user registration.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian 4.0 / --- / MySql 5.0.32-Debian_7etch6 / PHP 5.2.0-8+etch11 / 9.2.1


profago wrote
I have solved my problem setting in database +1 gtm as default and hiding "timezone" during user registration.


I´ve got the same problem (instead of -12 hours mine is set -6 hours). I understand what you are saying to solve the problem.... except, because I´m new in using Dragonfly.....I don´t know where/what to change in order to get the right gmt.

Can you be more specific for me? Thanks for your help!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL, CPGNuke 8.2b: Dragonfly 9.0.6.1


Default DF Timezone is set in Forums/Configuration. I'm not saying it's a logical place Big grin (Most people will look in General Preferences), but that's where it is.

To be honest I don't remember how I set the default DST. I think I set it directly in the database for the anonymous user.

Changing timezone in forums config won't change anything for registered users, only for new users.
Old users will have to change their timezone themselves. Or.. you change it directly in the database. But watch out then: timezones/DST-zones have special codes, it's not simply the difference in hours.

Good luck!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/5.0.24/5/9.1 CVS


alva wrote
Default DF Timezone is set in Forums/Configuration. I'm not saying it's a logical place Big grin (Most people will look in General Preferences), but that's where it is.

Hmm, that part I knew already and is set in de right timezone. So maybe it´s just how you say :

alva wrote

Changing timezone in forums config won't change anything for registered users, only for new users.
Old users will have to change their timezone themselves. Or.. you change it directly in the database. But watch out then: timezones/DST-zones have special codes, it's not simply the difference in hours.

That last part is something I rather not do without exactly knowing whát I´m doing...some one an idea?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL, CPGNuke 8.2b: Dragonfly 9.0.6.1


alva wrote
Default DF Timezone is set in Forums/Configuration. I'm not saying it's a logical place (Most people will look in General Preferences), but that's where it is.

The reason this is is this is only used in the forums and in PM's by function create_date
in includes/phpbb/functions.php if the user's timezone is unset.

Default time for the rest of the core is GMT if the users time is unset.

Check out the following module it allows the user to set their timezone and is based on whether the users computer time match the timezone set in config

AKA Akamu / Read these and your life will be successful | Find a Repair
--
Mods and Professional Support via YIM

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
win32 / Apache 1.3.33 / MySQL 4.1.16/PHP 4.4/CPG-CVS ( browsers: Mozilla 1.7.x / IE6 / Opera 8.0)


Thanks! I´ll try if this solves my problem.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL, CPGNuke 8.2b: Dragonfly 9.0.6.1


Jetsgeklets wrote
Thanks! I´ll try if this solves my problem.


And..., did this solve your time issue Dancing

He who wants to harvest happiness has to spread humor first...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.5-1.358smp, Apache, PHP 4.3.10, MySQL 4.0.24-standard, CPGNuke : Dragonfly 9.0.5.0


No, the timezone in my 'statistics' is still set -6 hours Sad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL, CPGNuke 8.2b: Dragonfly 9.0.6.1


Jetsgeklets That was a bug in statistics: fixed /cvs/html/modules/Statistics/index.php new revision: 9.10; <br />

AKA Akamu / Read these and your life will be successful | Find a Repair
--
Mods and Professional Support via YIM

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
win32 / Apache 1.3.33 / MySQL 4.1.16/PHP 4.4/CPG-CVS ( browsers: Mozilla 1.7.x / IE6 / Opera 8.0)

All times are UTC