Dragonfly CMS v9 ⇒ CPG-BB (forum) :: Archives ⇒ How to setup Multi-Forums? :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Modules & Blocks CPG-BB (forum) ⇒ Archives

Archived ⇒ How to setup Multi-Forums?


Sorry to bump this thread, but the question has not yet been answered. Which way is the best?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD/1.3.33 (Unix)/4.1.13-log/4.4.0+5.0.4(Using 4.4.0)/9.0.5.0 for teenout.com


Ok.
I have the multi-forums setup and running on our site, actually we have an additional 5 forums setup, if you visit you will see why we have done this.

However the only problem I am having at the moment is that these additional Forums are not showing up in the Admin privilages.
This is where you can give certain admins certain privilages, new forums are not there.

This is the only problem I am having at the moment, so any help would be greatly appreciated.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache 1.3.37/MySQL 4.1.21/PHP 4.4.4/Dragonflycms 9.1.1


I've setup a second forum area on my site which went ok but when i go into the admin area for it i get this up:

Fatal error: Call to undefined function: session_pagestart() in public_html/worldinagrainofsand/modules/fh_forums/admin/index.inc on line 30


Also basically I have transfered that forum from another site and I copied the database tables and replace the automaticaly generated ones in the new location and although the old forum categories are coming up with the right post counts there are not any posts in it...also I tried to transfer my users over from the old site to the main one and that didn't work and now my site is saying that it has 307 members when it only really has 7 (before adding the other sites members).

According to my admin panel I am using the lastest version of Dragonfly.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.34 (Unix)/4.0.25-standard/4.4.0/9.0.6.1

Last edited by Ploppy on Wed Dec 14, 2005 4:19 pm; edited 1 time in total


[EDIT]

I figured out how to fix the error above...I changed the index.inc file and on line 27 I put the exact path to the module and not the variable itself:

$Source: /cvs/html/modules/fh_forums/admin/index.inc,v $ $Revision: 1.2 $ $Author: djmaze $ $Date: 2005/04/25 19:31:20 $ **********************************************/ if (!defined('ADMIN_PAGES')) { exit; } if (!can_admin('fh_forums')) { die('Access Denied'); } global $db,$lang; $showblocks = 0; if (empty($_POST['send_file']) && !isset($_POST['cancel'])) { require('header.php'); define('IN_PHPBB', 1); $module_name = ucfirst($op); $phpbb_root_path = "modules/fh_forums/"; define('IN_ADMIN', true); include($phpbb_root_path.'common.php'); $userdata = session_pagestart($user_ip, PAGE_INDEX);

Now all I need to do is to transfer the users from my other site to my main one and transfer all of the posts over from that place to my main one...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.34 (Unix)/4.0.25-standard/4.4.0/9.0.6.1


Got a secondary forum up and running and its great. My only request, and I have searched and not seen this one yet, would be to add a drop-down to the Newsletter Pro for the ability to choose which forum tables are added into the newsletter when manually sending one out to a specific group.

This is probably not the best topic to post this request in, and if it needs to be requested elsewhere I will gladly do it.

Otherwise my secondary forum works REALLY well...thank you to the dev team for all your hard work!!

EHP Webmaster
www.ehpdesigns.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS / Apache 1.3.34 / MySQL 4.1.22 / PHP 4.4.7/ DF 9.1.2.1


that would be something to request to musox, the maker of newsletter pro. it wouldnt go into the forums

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33 (Unix)/4.0.22-standard/4.3.9/DF 9.x


Strike that, everything is not working fine with my Secondary Forum. I am unable to post anything (I can create categories and topics without issue though).

The error I get is this:
Fatal error: Call to undefined method sql_db::escape_binary() in /home/xxxx/public_html/includes/phpBB/functions_post.php on line 146


I just updated my functions_post.php from the CVS as I was getting the bbcode_uid errors which it stated the updated version removed the need for.

The error I was getting before I updated the functions_post.php was this
cache/tpl_PH2_Blue_forums#posting_attach_body.html.inc

* Notice line 24: Undefined index: POSTED_ATTACHMENTS_BODY

modules/Forums2/posting.php

* Notice line 396: Undefined index: topic_type

includes/db/db.php

* CMS Warning line 51: On /Forums2/posting.html While executing query "INSERT INTO cms_forums2_posts_text (post_id, post_subject, bbcode_uid, post_text) VALUES (5, 'Another Test Post', '', 'Test Post')" the following error occured: Unknown column 'bbcode_uid' in 'field list' In: /home/xxxx/public_html/includes/phpBB/functions_post.php on line: 155


Is there something else that needs to be updated that I'm missing here?

EHP Webmaster
www.ehpdesigns.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS / Apache 1.3.34 / MySQL 4.1.22 / PHP 4.4.7/ DF 9.1.2.1


I was successfully able to get a secondary Forum installed on my demo site this morning. And I even pulled all the updated files from DF CVS as well. But I get the same error. I get UID and "Call to undefined method sql_db::escape_binary()" errors.

Is anyone else having this issue. Does anyone have a zipped copy of their secondary forums that works and can post to? I can create categories, forums, preview posts, etc...but my issue lies when I'm actually submitting the post.

EHP Webmaster
www.ehpdesigns.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS / Apache 1.3.34 / MySQL 4.1.22 / PHP 4.4.7/ DF 9.1.2.1


What about being able to move threads between the various multi-forums??? e.g move thread from forums1 to forums2 etc.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.34 (Unix)/4.0.25-standard/4.4.0/9.0.6.1


its not possible unless you do it manually in the db which would take forever. I am hoping forums pro might come up with a solution for this. I asked here: myndworx.com/ForumsPro...t=124.html
and am awaiting a response

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33 (Unix)/4.0.22-standard/4.3.9/DF 9.x

All times are UTC