Support ⇒ New installations :: Archives ⇒ Issue with picture gallery :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

Archived ⇒ Issue with picture gallery


Hey, I installed the latest version, and have one issue with the picture gallery. When a user attempts to upload an image, I get this error:

Parse error: parse error in /usr/local/apache/htdocs/includes/imaging/imaging.inc on line 33

Fatal error: Undefined class name 'graphic' in /usr/local/apache/htdocs/includes/coppermine/picmgmt.inc on line 123

Can anyone help?

Thanks,
Scott

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


Please update your site link and server specs (admin.php?op=info) and we would be glad to help Smile

AKA Akamu / Read these and your life will be successful | Find a Repair
--
Mods and Professional Support via YIM

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
win32 / Apache 1.3.33 / MySQL 4.1.16/PHP 4.4/CPG-CVS ( browsers: Mozilla 1.7.x / IE6 / Opera 8.0)


I update my profile. Thanks in advance! Big grin

akamu wrote
Please update your site link and server specs (admin.php?op=info) and we would be glad to help Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


Here's my op=info output:
Setting Value
CMS Root /usr/local/apache/htdocs/
Core Root /usr/local/apache/htdocs/includes/
CMS Version 9.0.5.0
PHP Version 4.3.2
GD Version N/A
MySQL Version 4.0.16-log
Session save_path /tmp
Owner root (0)
Group 0
System FreeBSD yongsan15.com 4.9-RELEASE FreeBSD 4.9-RELEASE #0: Mon Sep i386
Build Date Nov 11 2003 01:38:38
Configure Command './configure' '--with-apache=/root/work/apache_1.3.27' '--with-mysql' '--with-openssl'
Server API Apache
Virtual Directory Support disabled
Configuration File (php.ini) Path /usr/local/lib/php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety disabled
Registered PHP Streams php, http, ftp, https, ftps

yoskim wrote
I update my profile. Thanks in advance! Big grin

akamu wrote
Please update your site link and server specs (admin.php?op=info) and we would be glad to help Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


I see a problem already, with the GD. Earlier I recompiled PHP to use GD and php -m now returns GD as an installed module, but somehow I'm guessing that either Apache or PHP in Apache is having an issue using it.



yoskim wrote
Here's my op=info output:
Setting Value
CMS Root /usr/local/apache/htdocs/
Core Root /usr/local/apache/htdocs/includes/
CMS Version 9.0.5.0
PHP Version 4.3.2
GD Version N/A
MySQL Version 4.0.16-log
Session save_path /tmp
Owner root (0)
Group 0
System FreeBSD yongsan15.com 4.9-RELEASE FreeBSD 4.9-RELEASE #0: Mon Sep i386
Build Date Nov 11 2003 01:38:38
Configure Command './configure' '--with-apache=/root/work/apache_1.3.27' '--with-mysql' '--with-openssl'
Server API Apache
Virtual Directory Support disabled
Configuration File (php.ini) Path /usr/local/lib/php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety disabled
Registered PHP Streams php, http, ftp, https, ftps

yoskim wrote
I update my profile. Thanks in advance! Big grin

akamu wrote
Please update your site link and server specs (admin.php?op=info) and we would be glad to help Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


GD Version N/A is look BAD since there is no GD library in PHP on your server.

Firefox is my Favorite Browser

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS


it's there when i do a php -m, but for some reason the version apache is using is incorrect.

xfsunoles wrote
GD Version N/A is look BAD since there is no GD library in PHP on your server.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


I'm at wit's end here. I tried the Image Magick route, and that didn't work either. I need to get this complete this week... please somebody help! I'm willing to pay someone upon getting this fixed. Please!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Free BSD 4.9, Apache 1.3.27, MySql 4.0.16, PHP 4.3.2, CPG Nuke 9.0.5


hey i am getting the same error no one can upload pics since i updated to latest version of dragonfly...

error:

Fatal error: Undefined class name 'graphic' in /includes/coppermine/picmgmt.inc on line 122

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


CMS Version 9.1.2.1
PHP Version 4.4.4
MySQL Version 4.1.21-standard (client: 4.1.21)
GD Version bundled (2.0.28 compatible)

PHP API CGI

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


(hey can't i edit my post?)

PHP API 20020918
Server API CGI

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


ok fixed the problem - the problem is that the imaging/gd2.inc file was empty for some reason - perhaps empty in the last df core ?

i grabbed the info off cvs and now works fine

if anyone else has this problem check to see if your gd2.inc file is empty and just upload the one from cvs

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


There is nothing wrong with the core or the release - more likely a problem with your ftp transfer or even that your ftp client does not treat inc files as ascii.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):

All times are UTC