Languages and alternative language support ⇒ i18n - l10n (languages) :: Archives ⇒ Nordic characters å, ä, ö, ø not showing correctly :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Indexi18n - l10n (languages)

Archived ⇒ Nordic characters å, ä, ö, ø not showing correctly


I have a problem with the swedish/norwegian characters å, ä, ö and ø who isn't showing as they are supposed to under my news articles (have no problems elsewhere on my website). For example in IE it shows "Postad av Mastah L?g, 19 november 2005"
(in english: "Posted by Mastah on Saturday, November 19, 2005")
This should be:
Postad av "Mastah Lördag, 19 november 2005".

Could anyone help me with this since I've search the forums but I cant figure out what to do!?

You can see for yourself here: www.danceaddict.nu/ind...ng=swedish

Edit: Just discovered that in Firefox it shows "Postad av Mastah L?rdag, 19 november 2005"

//Mastah Da n00b

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win 2003 Server/Apache 2.0.55/MySQL 4.0.26/PHP 4.4.2/Dragonfly CMS v9.0.6.1

Last edited by MrMastah on Sun Nov 20, 2005 2:38 pm; edited 3 times in total


i18n-l10n.com/News/art...sid=2.html

Could help you if this is an upgrade from a phpnuke site.

NEMINI.org, NEMINI.us, NEMINI.info, NYMINI.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
1.3.34 (Unix)/4.1.18-standard/4.4.2 /9.1.0.8 CVS


Thanks NEMENI for your quick reply! No, I'm not upgrading from a phpnuke site, I have upgraded from CPG-Nuke 8.2b to DF 9.0.6.1.
My webserver crashed two weeks ago and I had to restore the website from a backup. I upgraded Apache, PHP and MySQL to meet the reqs for running a Dragonfly website. Then I put a backup of the database (*.sql) back into MySQL and copied my website back into the webserver and everything worked. After that I updated from 8.2b to 9.0.6.1 and everything is working except for the date when an article is posted as described in my first post.

For me 8.2 worked without a glitch for a year, never had this kind of problem.

Any suggestions what to do next?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win 2003 Server/Apache 2.0.55/MySQL 4.0.26/PHP 4.4.2/Dragonfly CMS v9.0.6.1


You probably need to use 9.x language files, remember to backup and then delete the old language files sitting on your website.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Well I did that from the start, so that can't be it. Yesterday I installed the norwegian language files and the same problems occur for character ø (it should say Lørdag, but in IE it shows L? and in Firefox L?rdag)...

So I'm confused... since these characters diplay ok everywhere else!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win 2003 Server/Apache 2.0.55/MySQL 4.0.26/PHP 4.4.2/Dragonfly CMS v9.0.6.1


You could manually fix the problem modifing line 136 in modules/News/index.php to $datetime = utf8_encode(formatDateTime($row['time'], _DATESTRING));

But i really start to beleive that is MySQL 4.0.x that cause this kind of problems ... ?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Thank you NanoCaiordo, this fixed it! Very Happy
It's a strange error, I have it in one more place, when the Survey block doesn't have any surveys to show. There it displays ⇒ instead of ø in the message "Det er ingen sp㸲reunders㸫elser å vise" (There are no Surveys to display"). Maybe that has something to do with $content = sprintf(_ERROR_NONE_TO_DISPLAY, strtolower(_SurveysLANG)); in block-survey.php?

Can I fix that in a similar way? (I tried but I'm a php newbie so I couldn't make it work...) Confused

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win 2003 Server/Apache 2.0.55/MySQL 4.0.26/PHP 4.4.2/Dragonfly CMS v9.0.6.1


This is what you should get if you are using original Dragonfly language filesDet finns inga Undersökningar att visaThere are some differences that make me think that someone edited main.php handling it in a not proper way, loosing the encoding.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Hi there,

I've got similar problem.

I've done backup for whole database and then I've moved to different host-provider.

Now when I've added tables (phpMyAdmin) I get some strange characters, such as: ë , ç, Ë and Ç

I've got option characters set of file setup as UTF8, but still doesn't work.

Have you got any idea how can I solve this problem?

Thanks.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/MySQL/PHP/CPGNuke


More info about previos and actual verions of MySQL would be appreciated

but i guess you have switched from 4.0.X to 4.1.X

Please provide us more info, thank you.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Hi there & thanks fro reply

I dont know which version I used previosly.
Now i use MySQL 4.1.12-standard-log

Thanks.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/MySQL/PHP/CPGNuke


Perhaps it's just your Apache installation. I had the same problem when "AddDefaultCharset" was set to ISO-8859-1, but I just changed this to UTF-8 and it solved the problem.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
W2K/2.x/4.0.17/4.3.11/9.0.4


Thats why we already use in .htaccess (cvs)AddDefaultCharset utf-8 .. if you dont have that just add that line at the end of your main .htaccess file

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


I now this is an old post sorry but I couldn't find anything else close to what was wrong.
I am having the same problem as black
I have AddDefaultCharset utf-8 in my htaccess but every time I download the database I get the strange characters replacing quotations, bullets and some other symbols. Can someone please tell me how to make it stop

• becomes •
’ becomes ’
" becomes “
.......

PHP version 4.4.4
MySQL version 4.1.22-standard

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux::10337100::4.1.21::4.4.4::9.1.2.1


Crashwave what is your website url?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial

All times are UTC