Support ⇒ Explain Please :: Archives ⇒ URL Cloaking ~ fixed :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexExplain Please

Archived ⇒ URL Cloaking ~ fixed


Hiya guys and gals,

I am having an issue with my CPG site and can't seem to resolve it. Any help would be greatly appreciated.

My domain is web forwarded to my site dir on my server, and is cloaked as too show only the url and not the dir path in the url...

I do this as i have affiliate sites running with different information and services on the alternate sites.. ie.. one information site.. one sales site... ect...

The issue i have encountered is that when using CPG nuke the web forwarding works fine but the cloaking is not effective... ie.. it will cloak but then CPG seems to then display the url on to the dir path....

Strange.. I orignally thought it was the cloaking engine from my service provider but.. after giving them a serve and doing some testing.. found it not to be the case.. the cloaking worked fine when i changed the dir content to just contain some html pages...

this lead me to think that CPG uses i-frames or some sort of url forwarding... can anybody please confirm this for me...

and if possible... can anyone help me to stop this from happening so that my cloaking is liberated once again..

Cheers ahead guys...

later Skaters... Wink

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1

Last edited by Tinkabell on Tue May 16, 2006 1:56 am; edited 1 time in total


cloaking as you have it is probably setup by some htaccess file with rewrite conditions. dragonfly comes with it's own htaccess file with it's own conditions. not sure how your cloaking works to setup rewrite rules.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.33/4.4/4.3.11


Thanks for your reply... A good start for me.. but to no avail... I will enquire into how my provider is forwarding..

I did some testing however and these are the results..

I made changes to the htaccess file.. regarding the rewrite.. I commented out all lines that refered to rewrite for this file... no result...

I even deleted all code in htaccess and no result.. I think there is another way that cpg is rewriting the url....

Changed the rewrite base.. no result...

any other ideas... ? Very Happy

thanks in advance.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


For testing purposes only does it work if .htaccess is removed entirely? Do you have LEO enabled on the site in question?

There are no i-frames unless you've added them, but .htaccess is forwarding a bunch of stuff and even more if you have LEO enabled.

If it does work with no .htaccess then you can experiment with commenting all the RewriteRule lines and uncommenting one at a time to see which line is breaking it.

Diagon Alley - Top Design

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1


Hey thanks heaps for having a go guys...

Here is progress so far... LEO is off for the site!

Removed .htaccess file from root dir of the site... (is there other .htaccess files i should also be looking at?)

No change...

Symptoms are such:

When you load url...
Page loads with cloaking URL and Meta tags and heading correctly.. (you can see header tag at top of page)

! second later it is swapped with CPG module header tag and then the url displays to show local/sub_dir/module.php&file..ect ..

This to me sugests that CPG is rewriting still some how...

Any help with this on guys would be awsome... I guess it has more to do than the .htaccess files..

Cheers guys...

Later Skaters Wink

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


Tinkabell wrote
local/sub_dir/module.php&file..ect ..


that file has not existed since cpg 8.x

Please enter your server specs in your user profile! 😢


By "cloaking" do you by chance mean they use iframes to display your website? If so, try changing the global -> block_frames value in your cms_config_custom table to 0 and clear your websites cache folder (except for the .htaccess file).

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Win, Linux/1.3.34/4.0.26, 5.0.19/4.3.10, 5.1.2, 8.1.4(PostgresSQL)/9.0.6.1, CVS


Hmm.. ok.. did that... no good either.. I am pretty sure that it is not a iframes issue...

I will show you...

Go to www.kcb.com.au

notice that when you enter on the url the title heading at top of page and url display....

1 or 2 secs later... It changes to what the my CPG site dipslays and not what my cloaking engine from my url provider should display...hmm.. eik... Sad

thanks for the help

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


Still no good with this one guys..

It has really got me.. I even tried blowing the dir away and just testing an empty dir to see if the cloaking was working ok.. result... yup working with empty dir.

has to be something in CPG that is redirecting it from main page.

if the devs know anything about redirecting in CPG... any help would be great...

Cheers guys.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


I noticed www.kcb.com.au/ is using a frameset to redirect to another domain that DF is on. Its look like a URL Redirector.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS


i like your theme..

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


Yes correct.

My domain provider allows me to web forward kcb.com.au to a different url but at the same time cloaking the new url so to show www.kcb.com.au all the time... no matter what the url is...

this is the issue i have...

it works for a second and then some how.. DF uses its own url redirection and displays the DF url in the address bar.. not the cloaked url....

Any ideas would be great...

THanks again...

doing great so far guys thanks

Cheers..

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


Maybe looking at the following code from cmsinit.inc could get you closer to the solution.

$BASEHREF = ($_SERVER['SERVER_PORT'] != 443 ? 'http' : 'https') . '://'; $BASEHREF .= (isset($_SERVER['HTTP_HOST']) ? $_SERVER['HTTP_HOST'] : $MAIN_CFG['server']['domain']); $BASEHREF .= $MAIN_CFG['server']['path'];

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/5.0.24/5/9.1 CVS


Thanks for the Shot.. But no good.. Modified these lines of code to no avail...

I even commented them out alltogether and no change...

Was a good shot thought.. Had my little heart pumping thinking it was close...

CHeers for the go...

Anyone else?

Thanks in advance... you guys rock...!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.0.6.1


<script type="text/javascript">if (self != top) top.location.replace(self.location)</script>

this block frames.

open phpmyadmin (9.0.x) but 9.1 have it in admin panel
go to your cms_config_custom
find block_frames
change value 1 to 0
Close phpmyadmin

open FTP Client
go to the cache dir
remove file that got MAIN_CFG
close FTP Client

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Apache/1.3.34 (Unix)/4.0.25-standard/4.4.1/CVS

All times are UTC