General ⇒ FAQ (Frequently Answered Questions) :: Archives ⇒ Cookie problems :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexFAQ (Frequently Answered Questions)

Archived ⇒ Cookie problems


I tried EVERYTHING I could think of. Even little tweaks and tricks and it would not work. Ive never come across something like this before. The site works fine, you just cant register.

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2


Well guys, we got it working somehow. Hanksta is the one who orignally setup the site and I am just hosting it for him now.

We have, well he has, everything working now.

I did a fresh install of Cpgnuke and he imported his members, stories, etc over and left the cookies alone and he has it all working now. I have no idea wha thappened with the other one but its working fine now but he had to go into Major working to do it. Basically he manually imported sql dumps into certain sections. Ask him for a detailed post.

Lol Bigern75 2k posts man!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.31/4.x/N/a/9x


bigern75 wrote
I tried EVERYTHING I could think of. Even little tweaks and tricks and it would not work. Ive never come across something like this before. The site works fine, you just cant register.


I once had a logging-in problem and it turned out that it was because I had edited cmsinit.inc and saved it in the wrong encoding. I did "utf-8" (with BOM), instead of "ANSI+UTF-8" (without BOM). (Notepad ++).
The debugging would say that headers were already sent and a user would never stay logged in.
After saving cmsinit.inc in the correct encoding everybody could log in again!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/5.0.24/5/9.1 CVS


Problem Fixed; What I did was make a clean install of CPGnuke, and dump tables individually, and somehow this corrected the cookie error. Wierd but it worked

Come build a tutorial community with us.
www.Noob-Tutorials.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Operating system.: Linux:.|Apache version.:1.3.37 (Unix):.|PERL version.:5.8.7:.|PHP version.:4.4.4:.|MySQL version.:4.1.21-standard:.|DF.:9.x:.


sounds like some possible corrupted files with the first transfer.

.::..::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/2.2.6/5.0.86/5.2.8/9.3.2


No we re-tried about 4 or 5 times.

Come build a tutorial community with us.
www.Noob-Tutorials.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Operating system.: Linux:.|Apache version.:1.3.37 (Unix):.|PERL version.:5.8.7:.|PHP version.:4.4.4:.|MySQL version.:4.1.21-standard:.|DF.:9.x:.


Well with dumbing each table indivually, we just didnt touch the cookie tables. So therfor we didnt have to change them. So of course it worked. But this was the hard way of doing it. I really don't understand why it did this. Oh well its working now:
impact.gaming1o1.com

Ps. I probally shoulda mentioned that the last Server it was hosted on. Was a computer. Hanksta had setup a PC to be a dedicated server. This could have been why {expletive removed} acted so weird. I dunno.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.31/4.x/N/a/9x


What the hell? It replaced
*
*
*
*
With "I'm a moron" {expletive removed}

EDITED BY bigern75 WATCH YOUR LANGUAGE!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.31/4.x/N/a/9x


Lol its the rules wolfy Wink

Come build a tutorial community with us.
www.Noob-Tutorials.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Operating system.: Linux:.|Apache version.:1.3.37 (Unix):.|PERL version.:5.8.7:.|PHP version.:4.4.4:.|MySQL version.:4.1.21-standard:.|DF.:9.x:.


alva wrote
bigern75 wrote
I tried EVERYTHING I could think of. Even little tweaks and tricks and it would not work. Ive never come across something like this before. The site works fine, you just cant register.


I once had a logging-in problem and it turned out that it was because I had edited cmsinit.inc and saved it in the wrong encoding. I did "utf-8" (with BOM), instead of "ANSI+UTF-8" (without BOM). (Notepad ++).
The debugging would say that headers were already sent and a user would never stay logged in.
After saving cmsinit.inc in the correct encoding everybody could log in again!


Just wanted to add my .02
This post that you made, I don't think you understand how relevant it was. I was told by a member this morning that he was unable to post. I told him to clear his cache and all that. Still nothing. Ok, so I go check the cookie settings. Still nothing. Alright, time to hit CPGNuke website. HMMMmmmm. About a hundred posts to sift through, gotta love/hate the search function :shock:. So, cleared the cache on my database, nothing, went into phpmyadmin, everything is right, still nothing. Ok, by now I've been through about 25 threads, and I dare not make a post myself to be beaten to death by many members for not using the search function. Then all of a sudden, OMG, this post! I JUST DID THAT YESTERDAY! HAHAHAHAHAHA. Re-Downloaded the release and just overwrote the cmsinit.inc file until I can get something with BOM. Anyway, I posted this because if you look HERE, This suggestion is not in there. Neither is any of the other 10+ suggestions that everyone had. Why not? I understand when people get {expletive removed} about people "not using the search function" but when you have an error and it is pretty important to get your site back up. All those results can be a bit overwhelming. Wouldn't it make sense to put this relevant information in the FAQ where it belongs? Anyway, that's my .02. Thanks for the post by the way, you saved me from getting {expletive removed} and trying to reinstall.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.36/4.1.19-Standard/4.4.2/9.1.2.1


NewPokerPros wrote
Wouldn't it make sense to put this relevant information in the FAQ where it belongs?


Thanks for confirming the situation at hand. This information has now been added to the cookies entry in FAQ.
This site does have other entries where the importance of correct editing/saving of files is stressed. Even so no harm in adding it to the cookies entry in FAQ.
Thanks again.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/5.0.24/5/9.1 CVS


I had similar problem today:
I installed WAMP yesterday, everything was fine with DF installed on it.
Today when tunring on computer and starting WAMP there were cookies problem for my DF site.
So I finally find out my fix.
Go with phpMyadmin or whatever SQL changing platform your'e using and open cms_config_custom. Make it to show rows from 0 to 300 for example. Search for row cookie path and change it's value to "/" (without quotes), that fixed the mess for me. Hope this helps someone.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
-

All times are UTC