Support ⇒ Modules & Blocks ⇒ MediaWiki Dragonfly Integration - Version 0.4 - Beta ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexModules & Blocks

MediaWiki Dragonfly Integration - Version 0.4 - Beta Reply to topic

Go to page Previous 1, 2, 3, 4, 5, 6, 7

dekard wrote
Good news... I'm working on an 1.8.2 db that I'm upgrading to 1.9.3 so hopefully things will go smoothly.

I just wish Dragonfly was as attractive as Joomla, there's realy for comparison.


You can make Dragonfly look any way you like. Thats the great thing about the template system.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Multiple Setups


Before i F**** this up i don't see a LocalSettings.php

do i just create one and the code or copy the defulesetting.php rename it LocalSettings.php then make the changes

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux /Apache1.3.37/MySQL 5.0.24a/PHP 5.2.3/DragonflyCMS 9.2.1


wanted to say thank you for this module. We over at wowroster.net have been using this for sometime now. I have to say that you have done a great job.
www.wowroster.net/MediaWiki.html


cwells.net | FC7/Apache2/MYSQL5/PHP5/9.2
secret-order.us | FC7/Apache2/MYSQL5/PHP5/9.2RC
wowroster.net | FC8/Apache2+lighttpd/MYSQL5/PHP5/9.2

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FC/Apache2/MYSQL5/PHP5/9.2


Just have a quick question if someone might know the answer to this.

I have 2 sites that I have running dragonfly and this wiki integration. For the second one, I simply copied over the needed files from the first one and edited localsettings.php to point it to the new db tables.

When I bring up an edit screen on the new one, the images for the text editor are not showing up. The text is showing where they are normally located, but the buttons aren't linking from the folders contained in the MediaWiki folder.

I checked the links and the difference is that the new installation's link to those button image files are missing the subdirectory needed.

basically, this is the link to the file that is needed;
http://www.url.com/portal/modules/MediaWiki/skins/common/images/button_bold.png

and these are the links I am getting when I check the properties on the new install
http://www.url.com/modules/MediaWiki/skins/common/images/button_bold.png

Keep in mind, this thing is working otherwise. I can navigate around with no problem, I can edit, click any link and it works, no issues. The only problem is the way it looks for that image for the text editor buttons.

The difference between the sites are that the original site is installed to the root folder. The second site is installed into a sub folder.

Here is my localsettings.php file relevant info.
<?php # If you customize your file layout, set $IP to the directory that contains # the other MediaWiki files. It will be used as a base to locate files. if( defined( 'MW_INSTALL_PATH' ) ) { $IP = MW_INSTALL_PATH; } else { $IP = dirname( __FILE__ ); } $path = array( $IP, "$IP/includes", "$IP/languages" ); set_include_path( get_include_path() . PATH_SEPARATOR . implode( PATH_SEPARATOR, $path ) ); require_once( "includes/DefaultSettings.php" ); # If PHP's memory limit is very low, some operations may fail. # ini_set( 'memory_limit', '20M' ); if ( $wgCommandLineMode ) { if ( isset( $_SERVER ) && array_key_exists( 'REQUEST_METHOD', $_SERVER ) ) { die( "This script must be run from the command line\n" ); } ##} elseif ( empty( $wgNoOutputBuffer ) ) { ## ## Compress output if the browser supports it ## if( !ini_get( 'zlib.output_compression' ) ) @ob_start( 'ob_gzhandler' ); } $wgSitename = "Wiki"; $wgScriptPath = "/portal"; $wgScript = "$wgScriptPath/index.php"; $wgRedirectScript = "$wgScriptPath/redirect.php"; ## For more information on customizing the URLs please see: ## http://meta.wikimedia.org/wiki/Eliminating_index.php_from_the_url ## If using PHP as a CGI module, the ?title= style usually must be used. # $wgArticlePath = "$wgScript/$1"; global $MAIN_CFG; $wgArticlePath = ($MAIN_CFG['MediaWiki']['use_LEO']) ? "$wgScriptPath/MediaWiki/$1" : "$wgScript/$1"; $wgStylePath = "/modules/MediaWiki/skins"; $wgStyleDirectory = "$IP/skins"; $wgLogo = "$wgStylePath/common/images/wiki.png"; $wgUploadPath = "$wgScriptPath/modules/MediaWiki/images"; $wgUploadDirectory = "$IP/images";

Ideas on what needs to be changed to fix it?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.0.16)/2.0.61 (Unix) PHP/CMS Version 9.2.1

Last edited by Darkschneidr on Sat Sep 13, 2008 11:52 pm; edited 1 time in total


My first instinct is that it has something to do with the $IP reference, but I just wanted to ask. I tried to install following the instructions to the letter.

I realize I could probably just copy the folder over to where it wants it and build that folder structure (which I have done actually for a workaround temporarily), but I'm looking for a more permanent solution in case I encounter something else as a result.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.0.16)/2.0.61 (Unix) PHP/CMS Version 9.2.1


Try this...

$wgScriptPath = "/portal/";

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2.2.9/MySql 5.1.59/PHP 5.2.17/CPGDragonfly 9.3.3.0


I tried it, but it added another /portal to the url so it said /portal/portal/etc...

So I removed the / infront of portal
$wgScriptPath = "portal";

That seems to have fixed it, except now all of my links have /portal/portal in them and don't work. SO I'm having to put the "/portal" back to fix the interlinking.

I'm comparing a stand alone install to the integration to see what the differences are in the way it links, perhaps something will turn up.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.0.16)/2.0.61 (Unix) PHP/CMS Version 9.2.1


Don't ask me how, but it's linking to images and articles correctly now for some reason after I changed it back to using "/portal".

Ah well. Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.0.16)/2.0.61 (Unix) PHP/CMS Version 9.2.1


Since Mediawiki 1.13, the authentication module doesn't work because the AutoAuthenticate hook is deprecated. You must use UserLoadFromSession instead.

Therefore, in DragonflyModule.php, you must change:
$wgHooks['UserLoadFromSession'][] = 'fnAuthServerMagic';

function fnAuthServerMagic($user,&$result) {
global $userinfo;
global $wgUser;

if (is_user()) {
$username = $userinfo['username'];
$realname = $userinfo['name'];
$useremail = $userinfo['user_email'];
} else {return true;}

$user = User::newFromName($username,$validate='valid');
if ($user->getID()==0) {
$user->addToDatabase();
$user->setEmail($useremail);
$user->setRealName($realname);
$user->setToken();
$user->saveSettings();
}
else {
if($user->loadFromDatabase()) {
$user->saveToCache();
$wgUser = $user;
$wgUser->setCookies();

}
}
if (can_admin('MediaWiki')) {
$user->addGroup('sysop');
$user->addGroup('bureaucrat');
}
return true;
}

And it should work better!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux gentoo/apache2/mysql5.0/php5.2/dragonflycms 9.1.2.1


I had a recent problem with my install of MediaWiki after my host upgrade to a newer version of PHP. Whenever I tried to save a page, I got this message:
"Your edit has been rejected because your client mangled the punctuation characters in the edit token"

The culprit was the php setting "magic_quotes_gpc" set to being on. I followed instructions provided by my host to modify that setting and it fixed the issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9/Apache 1.3.36/MySQL 4.1.18/PHP 5.1.4/CPG Nuke 9.1.0.8 (Modified)


thanks for you share

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
MySQL 5.0

All times are UTC
Go to page Previous 1, 2, 3, 4, 5, 6, 7


Jump to: