Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Still no mail sent ... :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Still no mail sent ...


Ok I know this is another mail about mailing problems but trust me I read them ALL ! (I have IIS)

Here are my settings in e-mail preference admin page :

authorize html in e-mail : Yes
Use SMTP instead of Php : Yes
SMTP Hosting address : localhost
Server Authorization : No
no login nor password

I tested ok my SMTP server (I put a test mail in the pickup directory and I receive it in my yahoo mail). I changed to SMTP port from 25 to another, because I was always Hijacked by spammers who were using my computer as a sending platform.

Anonymous access on my SMTP server, All IP recognized as virtual SMTP server ...

I just can't see what's wrong !

Thank you for the help

Sebmex

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


First we should need the actually error that you get when you try to send an email...

but i can already see your problem
sebmex wrote
I changed to SMTP port from 25 to another

Did you let the php script know about the changes? Check includes/classes/smtp.php for the connection port number Wink

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


hum interesting indeed !!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


Also make sure you have your Server Domain set in Main Settings:General.

I just had this problem and that was my fix.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9/Apache 1.3.36/MySQL 4.1.18/PHP 5.1.4/CPG Nuke 9.1.0.8 (Modified)


ok, I modified the smtp.php file with the correct port, but still the same. My test mails via smtp server are still working (drop in pickup directory).

I still get this error on page :

Member mail: Message could not be sent.
Mailer Error: SMTP Erreur: Impossible de connecter le serveur SMTP .Admin mail: Message could not be sent.

Mailer Error: SMTP Erreur: Impossible de connecter le serveur SMTP .

------------------

Here is my Site Domain setting :

sebanezo.zapto.org

and my website address (from outside) is sebanezo.zapto.org

is it correct ?

Thanks for helping me on this one !

Sebmex

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


use localhost as SMTP host address in Admin -> Main Settings -> Mail

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


for some reason in my settings i had to use www.website_address.com , not http://website_address.com, then it worked

Pretzy's Place Pertzel Family Tree History Genealogy
Riverlife Church Henty

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP_Apache 2.2.2_MySQL 5.0.21_PHP 5.1.4_CPGNuke 9.1.1


that's what I did !

I have only : sebanezo.zapto.org

in mail settings I have "localhost".

Sebmex

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


then use "localhost" within you SMTP settings in php.ini as well.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Hi, sorry for the delay, I was away.

I went into php.ini and it was already set up to localhost.

BUT the SMTP port number was still 25, so I changed it to the new port (same as smtp.php file).

Still the same problem !! (even after full restart)

I have a doubt about the way to configure SMTP port in IIS though.

Correct me if I am wrong, but I have to go to Default SMTP Virtual Server Properties, in General tab and click Advanced and change TCP port from 25 to the new one.

Am I correct or wrong ? Missing another thing in IIS ? I still can send test mails when dropiing a mail in text file in the pickup directory ...

Thank you, I think I am going to get mad soon !

Sebmex

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


try putting www. before your domain name

Pretzy's Place Pertzel Family Tree History Genealogy
Riverlife Church Henty

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP_Apache 2.2.2_MySQL 5.0.21_PHP 5.1.4_CPGNuke 9.1.1


I have put www.sebanezo.zapto.org

even if my website address is (http://sebanezo.zapto.org), wierd because it is still accessible, even with the www. ...

damn it, still the same problem !

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


up !

any other idea guys ? I'am stuck ...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr


I noticed that you are using WinXP SP2. Is this IIS with SMTP supported Installed? Just wondering. Because, if you did not install mail relay for SMTP it will not work.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


Hi,

thank you for participating to my thread !

I do have SMTP installed and running. As I said, I tested the SMTP in IIS and it works since my test mails are received by people ... actually it used to work before I changed of SMTP port ...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP SP2 / IIS 5 / MySQL 4.1 / PHP 5 / Dragonfly 9.0.6.1 fr

All times are UTC