Dragonfly CMS v9 ⇒ Modules & Blocks :: Archives ⇒ Problems installing IRCChat :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexModules & Blocks

Archived ⇒ Problems installing IRCChat


Hello. I have just downloaded and installed IRCChat on our site. The installation seemed to go well, but when I try to connect I get an error:

Loading Java Applet Failed

So what I would like to know is why it is failing? Is there some limitation from my webhost perhaps? A setting I need to change somewhere? Does the IRCChat directory need 777?

Thanks a lot. I've searched for all the IRCChat related threads to no avail.

Please enter your server specs in your user profile! 😢


probably your browser blocks java applet?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


No that isn't it, but thank you for the reply. Mr. Green

I have Java installed and properly working, and not only that, I can go to other websites that use the IRCChat module and it works perfectly. It just will not show up on my website.

Any other ideas?

Please enter your server specs in your user profile! 😢


do you have anything like the following within your .htaccess file?
RewriteCond %{HTTP_USER_AGENT} Java/ [NC,OR]

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Yes but not specifically that line. Here is my htaaccess file:

# CPG Dragonfly CMS # Copyright (c) 2004-2005 by CPG-Nuke Dev Team, dragonflycms.org # Released under the GNU GPL version 2 or any later version # $Source: /cvs/html/.htaccess,v $ # $Revision: 9.13 $ # $Author: djmaze $ # $Date: 2005/09/06 00:48:38 $ # Remove the pound sign on these 3 for production sites # if your server doesn't allow it then a Error 500 is given # php_flag display_errors off # php_value error_reporting 0 # php_flag register_globals 0 # deny most common except .php <FilesMatch "\.(inc|tpl|h|ihtml|sql|ini|conf|bin|spd|theme|module|exe)$"> deny from all </FilesMatch> # disable access to config.php and .ht* from a browser <FilesMatch "^(config\.php|\.ht)"> Deny from all </FilesMatch> <FilesMatch "error\.(php|gif)"> allow from all </FilesMatch> # if you use LEO, mod_rewrite is necessary <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{REQUEST_FILENAME} -f [NC,OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.*)$ - [L] # Check for Santy Worms and redirect them to a fail page #------------------------------------------------------------------- # Variant -1 # uncomment if you dont use LWP # RewriteCond %{HTTP_USER_AGENT} ^LWP [NC,OR] # Variant -2 RewriteCond %{REQUEST_URI} ^visualcoders [NC,OR] # Variant -3 RewriteCond %{QUERY_STRING} rush=([^&]+) [NC] # deny them RewriteRule ^.*$ - [F] #------------------------------------------------------------------- # if you use LEO and CPG-Nuke is installed in a sub-directory like '/html', # remove that # before RewriteBase and rename /html to the path of the sub-directory # RewriteBase /html # RewriteRule ^index\.html /index.php RewriteRule ^([a-zA-Z0-9_=+-]+)(/|\.html)$ index=$1 [L,S=5] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)(/|\.html)$ index=$1&file=$2 [L,S=4] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)$ index=$1&file=$2 [L,S=3] RewriteRule ^([a-zA-Z0-9_]+)/([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=$2&$3 [L,S=1] RewriteRule ^([a-zA-Z0-9_]+)/(.*)(/|\.html)$ index=$1&file=index&$2 [L] RewriteRule ^index=(.*[^/])/(.*) index=$1&$2 [N,L] RewriteRule ^index=(.*) index.php?name=$1 [L] </IfModule> # use custom error pages if you wish ErrorDocument 400 /error.php ErrorDocument 401 /error.php ErrorDocument 403 /error.php ErrorDocument 404 /error.php ErrorDocument 500 /error.php # disallow index viewing (like ftp) of directory # Remove # for production sites # Options -Indexes # for hosts that don't allow the above, we won't give people anything to look at <IfModule mod_autoindex.c> IndexIgnore * </IfModule> AddDefaultCharset utf-8 # disable mod_security: SecFilterEngine off

Please enter your server specs in your user profile! 😢


i can't even get this to install - i get db error - but no error - just the standard "administrator contacted"

but nothing

right from downloads 2.0.2

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


Do you have SQL queries enabled in debug?

Diagon Alley - Top Design

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1


duh - didn't think of that - lol

let me check it

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


includes/db/db.php
CMS Warning line 75: On /admin.php?op=modules&install=IRCChat While executing query "CREATE TABLE cms_ircservers ( server_id smallint(5) unsigned NOT NULL auto_increment, network varchar(40) NOT NULL default "", server varchar(40) NOT NULL default "", region varchar(25) NOT NULL default "", PRIMARY KEY (server_id)) TYPE=MyISAM DEFAULT CHARSET=NULL" the following error occured: You have an error in your SQL syntax;

it's the stupid config file with the database charset - to solve my ealier errors i had to use NULL - but changed it to utf8 and ircchat installed just fine - so i changed it back to NULL for my site to work...

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


includes/config.php
define('DB_CHARSET', NULL);

note NULL and not 'NULL'

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Well I have been trying to figure it out some more...

I put a plain html file on my site and embedded a different java chat applet in it and it works perfectly. So I don't think it's my webhost... or my settings... but I still have no idea what it could be.

I'm open to any suggestions as I would really like to get this module running, rather than using flashchat.

One a side note, I was able to install PJIRC as a standalone and it connects to our IRC server and works perfectly. It seems that it is just something about the installation of this module that is messed up somehow.

Please enter your server specs in your user profile! 😢


NanoCaiordo wrote
includes/config.php
define('DB_CHARSET', NULL);

note NULL and not 'NULL'



ahhhhh gotcha Smile

thanks nano

hey one more thing on irchat install - it won't show any blocks left or right...

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


dragonflycms.org/Proje...d=884.html

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


so - what needs fixed??

cmsinit?

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


yes and since you have just installed ircchat you can unistall it and reinstall .... or go trought each block => edit and make sure you enable IRCChat in the module list

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head

All times are UTC