Dragonfly CMS v9 ⇒ Modules & Blocks ⇒ [release] Spaw 2.01 wysiwyg for dragonfly 9.1.1 (also 9.2.x) ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexModules & Blocks

[release] Spaw 2.01 wysiwyg for dragonfly 9.1.1 (also 9.2.x) Reply to topic


This is maybe a thing that many have waiting for in dragonfly, it have been atleast many that have asked for it.

I have added latest spaw editor v2.01 to dragonfly and got it to work realy nice for submit news. Uploading of pictures/flash and most of the text formating seems to work with an modded submit.php, so you and your users may add nicely formated news.

But.. There is always a but Smile
Since the modded submit.php no longer removes html tags it can make it less secure for attacks, so use this mod at your own risk.

Download here: nukebiz.com/Downloads/...ils/id=93/

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 10/Apache 2.4.x/MySQL 5.x.x/PHP 7.1.x/Dragonfly CVS


Is there away to add more buttons to spaw like some of the forumtag options for bbcode?


cwells.net | FC7/Apache2/MYSQL5/PHP5/9.2
secret-order.us | FC7/Apache2/MYSQL5/PHP5/9.2RC
wowroster.net | FC8/Apache2+lighttpd/MYSQL5/PHP5/9.2

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FC/Apache2/MYSQL5/PHP5/9.2


Wow pitcher !!!
I have been waiting a looooong time to see something like this.
I can't wait to try it on my site.
Let you know how it worked out.

Wonder is the beginning of all wisdom.
Verwondering is het begin van alle wijsheid.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows xp/Apache 2.0/mysql 5.0.51a (client: 5.0.51a) php 5.2.5/ CPGNuke 9.2.1


I have just installed Spaw v2.01 and set the chmod etc etc as instructed in the install text.

I am ble to select spaw when trying to submit news but the text box where I would add my news text is showing up grey and I am unable to type.

Please help, anyoen else had this problem or am I missing something hehe

thanks in advance

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS Linux / Apache 1.3.37 (Unix) / MySQL 4.1.21-standard-log / PHP version 4.4.4 / DragonflyCMS 9.1.1


also since installing spaw my news submision text box when using no editor or bbcode are very narrow, wouldnt bother me too much as long as spaw worked hehe

Another thing to note is thatin internet explorer the text box shows up white but still wont allow me to type and in firefox it shows up as grey and still wont allow me to type.

both bbcode and no editor when selected under submit news work fine excpet for the text boxes being very narrow.~

edit: I also notice that I do nto have a youtube button on the spaw editor that I have noticed on the demo page here test.pitcher.no/index....ile=submit

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS Linux / Apache 1.3.37 (Unix) / MySQL 4.1.21-standard-log / PHP version 4.4.4 / DragonflyCMS 9.1.1


New version out. Fixed some minor problems and added modded admin submit news.

Enjoy Wink

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 10/Apache 2.4.x/MySQL 5.x.x/PHP 7.1.x/Dragonfly CVS


Ddave_73 wrote
edit: I also notice that I do nto have a youtube button on the spaw editor that I have noticed on the demo page here test.pitcher.no/index....ile=submit


You can download youtube addon here.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 10/Apache 2.4.x/MySQL 5.x.x/PHP 7.1.x/Dragonfly CVS


Nice pitcher, great work 👏

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


I downloaded from here, but now when I go to post here's what my page looks like.
Attachment: untitled.png
Description
Filesize 38.69 KiB
Viewed 465 Time(s)
You are not allowed to view/download this attachment

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD 5.5/Apache 1.3.36/Mysql 4.1.16/PHP 4.4.2/9.0.6.1 (upgraded form phpnuke 7.8)


try to manually insert the correct paths to the config file for the spaw editor.

located in includes/wysiwyg/SpawEditor/config/config.default.php

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 10/Apache 2.4.x/MySQL 5.x.x/PHP 7.1.x/Dragonfly CVS


what am I supposed to edit.. I see lots of stuff that says it needs editing if I were using IIS but I am not.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
FreeBSD 5.5/Apache 1.3.36/Mysql 4.1.16/PHP 4.4.2/9.0.6.1 (upgraded form phpnuke 7.8)


Hi Pitcher,
I installed your module and everything seemed to went well.
But......
Apparently I need to do something more to enable the upload of pictures.
I suppose I have to do something within Spaw editor itself or so??
Please can you tell me where I have to make adjustments to let he filemanager and the upload manager of spaw to make it work?

Wonder is the beginning of all wisdom.
Verwondering is het begin van alle wijsheid.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows xp/Apache 2.0/mysql 5.0.51a (client: 5.0.51a) php 5.2.5/ CPGNuke 9.2.1


Have you created and chmodded uploads/spaw/files uploads/spaw/images and uploads/spaw/flash ?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows 10/Apache 2.4.x/MySQL 5.x.x/PHP 7.1.x/Dragonfly CVS


Yes I did.
I guess the program cannot find the path to the uploads directory?

I get this message: Notice: Undefined variable: st in
C:\Program Files\xampp\htdocs\voetbal\includes\wysiwyg\SpawEditor\plugins\spawfm\dialogs\spawfm.inc.php on line 569 and then a second one like it.
The variable st has something to do with dirs

What to do?

Wonder is the beginning of all wisdom.
Verwondering is het begin van alle wijsheid.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows xp/Apache 2.0/mysql 5.0.51a (client: 5.0.51a) php 5.2.5/ CPGNuke 9.2.1


Pitcher wrote:
try to manually insert the correct paths to the config file for the spaw editor.
located in includes/wysiwyg/SpawEditor/config/config.default.php

That confused me a little.
I was editing the config.default.php instead of the config.php
I only had to edit the path to the uploads directory.
Because my dragonfly is installed in a subdirectory of the root.

All is working fine now.
Thanks Pitcher!

Wonder is the beginning of all wisdom.
Verwondering is het begin van alle wijsheid.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Windows xp/Apache 2.0/mysql 5.0.51a (client: 5.0.51a) php 5.2.5/ CPGNuke 9.2.1

All times are UTC


Jump to: