Dragonfly CMS v9 ⇒ phpBB ⇒ phpBB (2.0.21/22) --> 9.1.1 ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Switch from X to Dragonfly v9 phpBB

phpBB (2.0.21/22) --> 9.1.1 Reply to topic


Ok, dunno who else has tried upgrading recently, but you probably found out like I did that the current conversion tool is busted.

Since I had some time today I decided to fix the conversion tool so it worked with the most recent phpbb (2.0.21/22).

it may work with earlier version of phpbb, but it all depends on if their schema has not changed prior to the versions I listed.

Everything works. It ported over all my tables, users, msgs, private msgs, groups, etc..

If you want to give it a shot and upgrade I have included it in this message.

Regards,

Zark Wizard
[edit: old version removed]

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


Thanks a lot ZarkWizard for your work!

If someone use this converter is invited to post back here the results of the conversion and the phpBB version used, thanks.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I have just finished using the converter. All of the forums, security, ranks, users are in and fine.

The only issue I have found is that alot of my users on phpBB did NOT have ranks (I use special ranks only) and so they are flagged as suspended in Dragonfly. They are all there but I had to edit each of them out of suspension because I'm not proficient enough in mySQL to change all suspends to not.

Thanks a bunch ZarkWizard! This was the final piece I needed to decide to make the switch.

.m@.

"Reality is merely an illusion, albeit a very persistent one. " - Albert Einstein

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
{GoDaddy Hosted} Linux/ 1.3.33 / 5.0.45 / 4.3.11 / 9.1.2.1


mdthomann wrote
I have just finished using the converter. All of the forums, security, ranks, users are in and fine.

The only issue I have found is that alot of my users on phpBB did NOT have ranks (I use special ranks only) and so they are flagged as suspended in Dragonfly. They are all there but I had to edit each of them out of suspension because I'm not proficient enough in mySQL to change all suspends to not.

Thanks a bunch ZarkWizard! This was the final piece I needed to decide to make the switch.


So you are correct.. No idea how I missed that one.. Guess cuz I was logged in as admin it never crossed my mind to look at the user list since I saw users were actually there..

OPPS.. Anyhow, I have corrected the suspension issue in this version of the convert tool.

I would edit my prior message and put it in there, but it seems I can't edit posts..

Either that or I didn't see the edit button.. Can I get an admin to delete the file from the first post, or if possible get the ability to edit the messages?
Attachment: phpbb to df 911 v2.rar
Description Fixed for the suspension flagging. Now correctly sets the suspension flag correctly.
Filename phpbb to df 911 v2.rar
Filesize 14.89 KiB
Downloaded 185 Time(s)
You are not allowed to view/download this attachment

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


ZarkWizard wrote
it seems I can't edit posts
That question has been asked and answered ever so many times, it rarely gets a reply these days. Probably the most definitive answer lies here:
dragonflycms.org/Forum...html#91910

btw, nice work on the converter Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu/Apache 2.2.22/MySQL 5.6.34/PHP 7.1.22/DragonFly 10.0.48.9418


Phoenix wrote
ZarkWizard wrote
it seems I can't edit posts
That question has been asked and answered ever so many times, it rarely gets a reply these days. Probably the most definitive answer lies here:
dragonflycms.org/Forum...html#91910

btw, nice work on the converter Smile


While I would agree somewhat, in a case like this though where there is an error in the first file, I would hate from someone to download the incorrect file version.

I just wanted to be able to correct the file in the first post so people would not have the suspension error.

I would still like an admin to correct the file in the first message or remove it.. just to make it easier for users upgrading. Smile

Thanks.. Figured since I did it for myself, no reason to make everyone else build their own wheel so to speak.. The guys here do enough for the community already.

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


Simplest solution is to add it to downloads, where you can update as you wish Smile

Point taken - old version removed. Unfortunately, legitimate needs like yours get caught up by the irresponsible approach from certain users in the past.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu/Apache 2.2.22/MySQL 5.6.34/PHP 7.1.22/DragonFly 10.0.48.9418


I'm using phpbb 2.0.21 and mysql 5.0.27. When I run it all the tables get cleared and the old data isn't copied over.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux 2.4.21-40.ELsmp // 1.3.36 // 4.1.21-standard // 4.4.2 // 9.1.1


jarro_2783 wrote
I'm using phpbb 2.0.21 and mysql 5.0.27. When I run it all the tables get cleared and the old data isn't copied over.


You did edit the config.php file right?

I would guess your settings are incorrect, but then again I could be wrong..

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


Phoenix wrote
Simplest solution is to add it to downloads, where you can update as you wish Smile

Point taken - old version removed. Unfortunately, legitimate needs like yours get caught up by the irresponsible approach from certain users in the past.


lol, indeed you are correct I could have done that.. Guess I am still getting use to the whole "CMS" thing..

Old habits and all... Smile

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


ZarkWizard wrote
jarro_2783 wrote
I'm using phpbb 2.0.21 and mysql 5.0.27. When I run it all the tables get cleared and the old data isn't copied over.


You did edit the config.php file right?

I would guess your settings are incorrect, but then again I could be wrong..


yes I did edit config.php. I opened up my two other config.phps and made sure I read it from them. There were no errors about could not connect to database or anything. Then when it ran it told me the correct tables, ie. copying phpbb_users to dragonfly_bbusers etc.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux 2.4.21-40.ELsmp // 1.3.36 // 4.1.21-standard // 4.4.2 // 9.1.1


jarro_2783 wrote
yes I did edit config.php. I opened up my two other config.phps and made sure I read it from them. There were no errors about could not connect to database or anything. Then when it ran it told me the correct tables, ie. copying phpbb_users to dragonfly_bbusers etc.


Odd... don't know what to tell you.. You are even running the same version of phpbb, and mysql as me...

I would doubt it's a phpbb problem... Are you running the most recent build of Dragonfly? (I know dumb questions, but I am trying to get a feel for your config)

I would like to track down your issue.. I have converted 3 systems over with it, and run numerous tests.. On phpbb .21 & .22.

If you go through the tables do any of the tables convert? Some of them should convert regardless.

Regards,

Zark Wizard

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
...


ZarkWizard wrote
You are even running the same version of phpBB, and MySQL as me...
even if MySQL version is the same it might be possible that he is using it with STRICT_TRANS_TABLES sql-mode which will give him a little problem.

In this case we have two choices only make the script compatible with that option or strip that option off my.ini.

In the case that you want to make your script compatible with sql-mode STRICT_TRANS_TABLES and you are in troubles i might able to help.

DragonflyCMS its already compatible with it STRICT_TRANS_TABLES ... not many out there Dancing

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


yeah that fixed it, I'll try it on my actual server (not just my laptop's testing installation) to see if that works. Is it likely that a proper web host would have strict mode enabled?

I like how dragonfly has separate admin accounts, it means wiping the forum users / normal users doesn't delete your admin account.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux 2.4.21-40.ELsmp // 1.3.36 // 4.1.21-standard // 4.4.2 // 9.1.1


I'm installing Dragonfly for the first time and trying to use the conversion tool ZarkWizard so kindly provided above to transfer over my phpbb 2.0.21 forums. I have category hierarchy installed on my forums. The first attempt I made did some strange stuff including reordering some of the topics into different categories. I also lost all the topics which were links, all sub-categories, and my DF admin account. I found the answer to the last issue was to make sure that the admin user name on the forums is not the same as the one on your DF installation. I could care less about losing the links. So far as the subcategories go, I went back to my original forums and edited all the sub-categories to make them all regular categories and tried again on a fresh installation of dragonfly (including dumping the database). However, it still reordered the topics/categories and didn't transfer any of the categories which were originally sub-categories. Can anyone suggest a method for manually transferring over the remaining categories?

Please enter your server specs in your user profile! 😢

All times are UTC


Jump to: