Support ⇒ Requests :: Archives ⇒ Admin to decide themes available for users :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexRequests

Archived ⇒ Admin to decide themes available for users


An other feature that could be nice to have:

Let Admin be able to choose what themes should be available for the users.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/Dragonfly 9.1.1

Last edited by Hogne on Sun Feb 25, 2007 8:16 pm; edited 1 time in total


Easy way to do that is to simply delete the ones that you don't want them to select.

But note that in 9.1.x you can NOT delete the default theme. But in this thread rigura shows how to hide default from user selection.

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4


Yeah, but if you have themes that you are modding and tweaking and developing, it would be nice to not let users select themes that will screw everything up!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/Dragonfly 9.1.1


True, but take a few minutes to load Xampplite on your PC and develop them there (you can copy your current site down to it db and all so you don't lose context). I didn't do this for the longest time, but could not consider doing it any other way now - changes are instantaneous as you can execute straight from your development code. And latest Xampplite includes PHP 5 and MSQL 5 so you can get ahead of the game testing-wise too.

If you really want to cover all bases, download the deprecated miniXAMPP too and run that with PHP 4, MSQL 4 and 9.0.6.1, and switch back and forth.

Neither miniXAMPP or Xampplite touch the Windoze registry either, so installation - and later removal - are easy. Or even put it on a thumbdrive.

Pro_News CM™ - Content Management for Dragonfly CMS™

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux / 1.3.39 - 2.4.9 / 5.5.42 - 5.6.16 / 5.4.37 - 5.5.11 / 9.4

All times are UTC
This forum is locked: you cannot post, reply to, or edit topics. Forum IndexRequests
Page 1 of 1