Support ⇒ Upgrades :: Archives ⇒ 9.1.2.1 Upgrade - Security Error - Bad Link :: Archived (page 2) ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

Archived ⇒ 9.1.2.1 Upgrade - Security Error - Bad Link


Still no luck.

I fixed the broken image. Cleared the cache in my browser, cleared cookies, cleared cache (except .htaccess), retried.. and still the same error.

It is one "unhappy camper"!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux /Apache 1.3.33/MySQL 4.1.11/ PHP 4.4.0/ Dragonfly 9.1.2.1


Here's a longshot, did you change the cookie names to something unique, or leave them as the defaults?

Diagon Alley - Top Design

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1


I left everything as the default settings.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux /Apache 1.3.33/MySQL 4.1.11/ PHP 4.4.0/ Dragonfly 9.1.2.1


Change them to something unique and do the un-cache and un-cookie hustle again.

Diagon Alley - Top Design

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/1.3.37/4.1.21-standard/4.4.4/9.1.1


Unfortunately I cannot do that in the admin menu because I cannot save any settings without getting the error page.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux /Apache 1.3.33/MySQL 4.1.11/ PHP 4.4.0/ Dragonfly 9.1.2.1


This should get you around your problem...


line 27 of /admin/modules/settings.php reads
if ($_POST['save'] != $CPG_SESS['admin']['page']) { cpg_error(_ERROR_BAD_LINK, _SEC_ERROR); }
change to
# if ($_POST['save'] != $CPG_SESS['admin']['page']) { cpg_error(_ERROR_BAD_LINK, _SEC_ERROR); }

.m@.

"Reality is merely an illusion, albeit a very persistent one. " - Albert Einstein

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
{GoDaddy Hosted} Linux/ 1.3.33 / 5.0.45 / 4.3.11 / 9.1.2.1


Thank you, thank you to everyone for their help!!

Mdthomann hacked me out so that I can save settings in the admin menu and approve users. I so appreciate all the help!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux /Apache 1.3.33/MySQL 4.1.11/ PHP 4.4.0/ Dragonfly 9.1.2.1


check if you have broken images in admin.php?op=settings

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Is session_save_path in /includes/config.php set to a valid directory that you can write to (it is at the bottom of the file)? If it is not it won't be able to save the session data file and you will get the bad link error constantly.

Having just moved my doc root to a new location I have found this out the hard way.

Please enter your server specs in your user profile! 😢


Mine is commented out... Maybe a change since 9.1.1

//session_save_path('/home/SOMETHING/tmp');

.m@.

"Reality is merely an illusion, albeit a very persistent one. " - Albert Einstein

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
{GoDaddy Hosted} Linux/ 1.3.33 / 5.0.45 / 4.3.11 / 9.1.2.1


It this case it uses the directory set in php.ini (session.save_path which defaults to /tmp or, in later versions of php the default tmp directory (/tmp or c:\WINDOWS\Temp for example), which you may or may not be able to write into. Since you know that you can write to your cache directory, uncomment the session_save_path and set it to your DF cache directory (just for testing). Delete your cookies. Clear the cache directory. Sign in again. See if it is working. You will get a file called sess_... in the cache folder if it is.

If the file is created but you still get the same problem then this isn't the issue and you can uncomment it again. If it is fixed then you need to look into why you can't write to the directory in php.ini because you should be able to write to it or you can set up a new directory or whatever (but don't leave this set to your cache directory in a production system since it is a potential security risk).

Please enter your server specs in your user profile! 😢


You are correct.... php.ini set to /tmp

I changed it to the cache dir and saw the session files. Still have security error if trying to register. I have changed back to default.

Thanks for trying.

.m@.

"Reality is merely an illusion, albeit a very persistent one. " - Albert Einstein

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
{GoDaddy Hosted} Linux/ 1.3.33 / 5.0.45 / 4.3.11 / 9.1.2.1


NanoCaiordo wrote
check if you have broken images in admin.php?op=settings

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


No missing images....

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
{GoDaddy Hosted} Linux/ 1.3.33 / 5.0.45 / 4.3.11 / 9.1.2.1


try using the "web developer" add-on for Firefox ... just because you didn't fix the problem by removing a security check.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head

All times are UTC