Dragonfly CMS v9 ⇒ Downloads Pro ⇒ Screenshot thumbs won't display (page 2) ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexModules & BlocksDownloads Pro

Screenshot thumbs won't display Reply to topic


Perhaps your issue is unrelated to this one.

This is specifically about jpg files - png and gif already work okay.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


yeah - i have uploaded jpg files - i'll pm you phoenix to show you the site i'm working on....

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


I don't have time tonite - I'm heading off now.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


that's cool - i pm'd you the site i'm working on - but mainly the prob is this:

i uploaded .jpg files (wallpaper) into the downloads pro and used same images as screenshots - when i upload, all seems success - but when i view the downloads listing - all the screenshots are red-x'ed on IE - and empty entirely on Opera - just a link - no image...

when i browse the directory uploads/downloads - the images and downloads are there - but no thumbs are there - as if nothing is created...

thanks

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


by the way - on downloads pro b3 - the screenshots link appeared and screenshot came up - but not on the dpro latest....

might just revert back to b3!
lol

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


You will notice there is a backslash in those stored images, so there is actually a small bug in the preg function - Nano will remedy and advise.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


(oh i miss this community)

thanks phoenix!

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


replacing preg function still doesn't work...

i deleted and reuploaded and still no thumbs generated - same prob....

any other tips?

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


you mean like return preg_replace('/\.jpeg$/', '.jpg', implode('.', $file).image_type_to_extension($imagetype));

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


yeah that didn't work for me...

this is the PM i sent to phoenix:

ok - just realized something
(but still not sure why it's not working - but did manage to make it work)

ok - in my downloads of my site - i want my members to download wallpaper for their pc's - so - i upload .jpg images for wallpapers... and i wanted a thumbnail displayed so they can see before they download (which wasn't working)

so - i made it work by basically reuploading the same file via the screenshots url/file line - i figured that i could just paste the url location of the image from "uploads" and the thumbnail generator of dlp would create the thumb and stick it in "uploads/images" like it's supposed to - but no - doesn't work that way...

the way i made it work - is i added the file "image.jpg" and it uploaded it fine into "uploads" as "2_image.jpg" - then i have to reupload via the file link for screenshot (instead of pasting the actual image location of "uploads") and so - it uploaded "image.jpg" into "uploads/images" as "2_image.jpg" and "2_image_thumbs.jpg"

so basically - that way works - but very redundant in having both fullsize image files in 2 directories....

so now - since it's not technically a real bug - can it be "fixed" so that people can upload images as wallpaper and display the screenshot off that same wallpaper image location instead of reuploading 2 fullsize images that get put into 2 directories just for the thumb in order to be created?

basically - with downloads pro b3.zip files - i uploaded the image - landed in "uploads" - and selected the same file location url as the main image - and it created the screenshot link - off that same location - without uploading again - and popped up just fine...

ok - my brain hurts now - hope that explained it well - what can we do now?

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


Well, I've tested the fix with PHP4.4.4 and 5.2.0 and both work fine using this,

dragonflycms.org/cvs/h....inc?v=9.8

With DLpro v3.0.0.10

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


not sure if you're understanding the problem i'm experiencing...

i'm uploading .jpg images - as the actual download

and want to use that very same image for the screenshot...

so when i upload the image - it places it in the "uploads" directory...
but when i use the "uploads/image.jpg" direct file link for the screenshot url - it doesn't create the screenshot like it's supposed to...

so instead - i have to upload the very same image again as a file into the screenshot url/file field - and thusly it uploads the "image.jpg" into "uploads/images" directory... creating the "image.jpg AND image_thumbs.jpg" images - separately - so doing it that way - i have "image.jpg" in "uploads" AND "uploads/images" directory - along with "image_thumbs.jpg" - basically making it redundant in uploading 2 fullsize images...

the screenshots work just dandy if you are uploading a file or program into "uploads" and then use an image for the screenshot - in which it works as it should

but my problem is that i want to upload actual images - not programs...


have you tried uploading a fullsize image as the download?
and linking the actual image location (uploads/image.jpg) as the screenshot?

and did that work?

because that's not working for me - which is what i'm experiencing - if on your end it works just fine - let me know and i'll delete everything relating to downloads pro and retry from scratch...

thanks guys!

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


ok i think i found something - unless i'm just totally wrong because i don't have the best access right now (been housesitting for the week away from my PC) - anyway...

i feel the reason the thumb isn't being created via the URL link for it is perhaps this line of code in themes/yourtheme/downloads/manage.html:

URL: <input type="text" name="image" id="image" size="50" maxlength="255" /><br />

the id/name is "image" - though in modules/downloads/add.php there is no code to pull the ['image'] value - i only see ['images'] and ['add_image'] (i'm looking at both files under 'screenshots' area)

so i'm assuming this is why it isn't creating the thumb off the actual link - any suggestions?

thanks Smile

[]D [] []\/[] []D
Check out my bear site - www.insidebear.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
RHL7 2.6.9-67.0.15ELsmp/A1.3.41(Unix)/MySQL4.1.22-standard/PHP5.2.5-ZO/Dragonfly 9.1.2.1


I finally understand what you are doing.
Whats the width and the height of the image that you want to use for downloads and screenshots?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


i think i have the same problem, was there ever a fix for this?

do a search for failure on www.google.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
freebsd/apache_1.3.31/mysql5.0.67/php5.2.8/upgraded from 9.0.6.0 to 9.0.6.1 to 921/ GD Version bundled (2.0.34 compatible)

All times are UTC


Jump to: