General ⇒ FAQ (Frequently Answered Questions) :: Archives ⇒ Please decipher this error message... :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexFAQ (Frequently Answered Questions)

Archived ⇒ Please decipher this error message...


I tried the "Review" option on one of my site's downloads, but keep getting this error message:

On /index.php?name=Downloads&review=40
While executing query "SELECT COUNT(*) FROM WoW_downloads_ratings WHERE lid='40' AND (ip='?/' OR uid='2')"

the following error occured: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='

In: /home/freak6/public_html/modules/Downloads/include/review.inc on line: 119


Can someone please decipher it? BTW, my site is English only, and I noticed the error says something about latin/swedish. Does this provide a clue?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS/Apache v1.3.34/MySQL v4.0.25-Standard/PHP v4.4.1/CPGNuke v9.0.6.1


Please check FAQ and search on illegal mix of collations and read
[url=http://dragonflycms.org/FAQ/cat=17.html}Illegal mix of collations fix{/url]

Haven't much time to go into detail but take care as this involves delving into SQL

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux, Apache 2.0, SQL 5.0.86-log (client: 4.1.22), PHP 5.2.11 DF 9.2.1


Fixed link, why edit is disabled here beats me
Illegal mix of collations fix

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux, Apache 2.0, SQL 5.0.86-log (client: 4.1.22), PHP 5.2.11 DF 9.2.1


Gamekeeper wrote
Fixed link, why edit is disabled here beats me
Illegal mix of collations fix


Thanks for the info. Which config.php do I edit? There is no line in my root config.php that matches the one in the link.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux OS/Apache v1.3.34/MySQL v4.0.25-Standard/PHP v4.4.1/CPGNuke v9.0.6.1


look at:

includes/config.php

www.greenday2k.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


if you have upgraded to 9.1.1 or higher you should delete the config.php in your root it is no longer used

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Multiple Setups

All times are UTC