Dragonfly CMS v9 ⇒ CPG-BB (forum) :: Archives ⇒ [solved] RSS Forum Feed Question (ampersand) :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Modules & Blocks CPG-BB (forum) ⇒ Archives

Archived ⇒ [solved] RSS Forum Feed Question (ampersand)


I’ve got 2 Dragonfly sites running on the same server, ramjaw.org and YellowstoneSavage.com. Both are running 9.1.2.1 straight from the download, no mods or code changes. When I go to ramjaw.org/rss/forums.php I get different errors depending upon the browser, but the bottom line is it doesn’t work. Going to the same url at the YellowstoneSavage.com site works fine. I’ve looked at every option in the forums admin menu and not found anything that refers to RSS. Is there a option to turn this on somewhere?

My second related question is there an easy way to add a link to the RSS feed page? I see the file xml_80x15.png in the images/buttons folder.

TIA

XP sp2/2.2.4/5.0.41/5.2.2/
ramjaw.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP sp2/2.2.4/5.0.41/5.2.2/


Got them to work like - ramjaw.org/rss/news2.php and yellowstonesavage.com/rss/news2.php ..hmm These are for news however. Do you have which forums are to be "fed via RSS" selected within your forums admin area?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
[CentOS release 4.6 (Final)] | [Apache 1.3.37] | [MySQL 4.1.21-standard-log (client: 4.1.21) | [PHP 4.4.7] | [DF 9.2.1] | [FPro 2.0.2]


sultan wrote
Do you have which forums are to be "fed via RSS" selected within your forums admin area?
Uhh under the forums admin I can see "Forums" "Members" and "Attachments" but I can't see anything related to RSS under those menus. (unless I'm looking so hard I can't see it for looking.) The only place I've found any reference to RSS is in the "Linking > Headlines" section and it doesn't seem to be what I'm looking for.

XP sp2/2.2.4/5.0.41/5.2.2/
ramjaw.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP sp2/2.2.4/5.0.41/5.2.2/


Forgot I am using Forumspro which is where that option is at in my case.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
[CentOS release 4.6 (Final)] | [Apache 1.3.37] | [MySQL 4.1.21-standard-log (client: 4.1.21) | [PHP 4.4.7] | [DF 9.2.1] | [FPro 2.0.2]


The URL for the ForumsPro rss feeds would be:

your.domain.com/rss/forumspro.php

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Debian 6.07/Apache 2.x/MySQL 5.x/PHP 5.3/DF 9.x


I FIXED IT!! Big grin

Boy this one was a head scratcher, but I got it. For the benefit of those that might have the problem in the future here is the problem and the solution. The problem was the RSS feed would fail with any browser or reader.

The root cause of the problem was I had forums with names like "Problems & Maintenance" "Electrical & Lighting". Do you see the problem? Well for a long time neither did, but the "&" ampersand sign was confusing the XML readers. When I replaced the "&" in the forum name with "and" everything started working.

XP sp2/2.2.4/5.0.41/5.2.2/
ramjaw.org

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
XP sp2/2.2.4/5.0.41/5.2.2/


@JuanSigned i had the same problem a while ago, just make sure that you use & amp; (without space) instead of &

this will also make xhtml validation tools happy

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC