Dragonfly CMS v9 ⇒ IIS Specific Issues :: Archives ⇒ Problem with password protected directory on server. :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexIIS Specific Issues

Archived ⇒ Problem with password protected directory on server.


guess i found a fix for it Razz thanks all..

anyway noticed another prob while testing the site. seems to me that if i am not logged in, and if i click some links in the main menu, they will prompt some kind of login access box like those we encounter in routers n stuff. any ideas? you can check it out... www.yckakis.com click on "Members List" in the main menu for example. The prompt appears. Some link doesn't produce that prompt. For example, the search link doesnt produce such errors. Could anyone enlighten me how to fix this? Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
WinOS2003/IIS/SQL4/4/9.1.2.1


its called password protected directory on the server.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Multiple Setups


hmmm.. show what should I do to remove this prompt and get the usual "Login to continue" pages instead? Is there a way to fix this? Thanks lots!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
WinOS2003/IIS/SQL4/4/9.1.2.1


look for a .htpasswd file in modules\Members_list and something like the following in .htaccess in that directory

AuthType Basic AuthUserFile /home/xxx/modules/members_list/.htpasswd AuthName "" require valid-user

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1


hi,

there isnt such files. In modules/member_list I could only see 1 file, "index.php". thats it. hmmm...

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
WinOS2003/IIS/SQL4/4/9.1.2.1


Sounds liek a bug in your IIS server, contact host and ask if he can upgrade to GNU/Linux with Apache Very Happy

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


Ahhh - that's not Apache! duh .htaccess/.htpasswd no work on IIS.
There's a different method for doing the same thing on IIS, but I forget how to do it now - pretty sure it's via the Internet Services panel on the server. Ask your webmaster to check the settings for that virtual directory

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1

All times are UTC