Support ⇒ Upgrades :: Archives ⇒ http 406 error in Blocks Administration :: Archived ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

Archived ⇒ http 406 error in Blocks Administration


When trying to adjust the layout in the Blocks administration I change the settings to what I want and then click on update changes but am presented with a http 406 not acceptable error Internet Explorer cannot read this webpage format (Blank screen in Firefox). Is there something whcih I haven't set correctly that someone knows of?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2/5.0.45-community/4.4.6/CPG 9.2.0.RC2


www.w3.org/Protocols/r...#sec10.4.7

In short: somehow the headers send between you and the server get messed up.
This can be anything, from software on your computer, thru a firewall/router, into a proxy to your server.

It is hard to guess what the problem is.
So if we know there is nothing between you and the server, other then the internet line, we can seek for errors in Dragonfly.

Preferably you un-install any crappy internet related software like Norton AntiVirus Internet Suite, unless you thankfully don't have that.
I understand that this will make Windows wide-open for all those known and unknown security issues, so maybe use a GNU/Linux Live CD to test your website.
This is as easy as:
1. download Ubuntu (or any other live distro) ISO
2. burn it on cd
3. reboot to cd
4. open browser
5. test website

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Fedora 25 / Apache 2.4.27 / MariaDB 10.1.26 / PHP 7.1.10 / Mercurial


What version did you upgrade from?
what theme are you currently using?
Does this occur when using default theme?

Admin - Great Lakes Web Designs
Theme Designer - WebSite Guru Designs
Site Admin - Families with Food Allergies

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.27-grsec/Apache 2.2.11/MySQL 5.0.67-community-log/PHP 5.2.8/DF 9.2.1


Hi, Upgraded from 9.1.2.1 I am using the dragonfly theme. I hadn't tried it with the default theme but I have now and I still get the same problem. I will try it on Ubuntu and see if the same thing happens.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2/5.0.45-community/4.4.6/CPG 9.2.0.RC2


Have tried this in Ubuntu through Firefox and when I clicked on Update changes it came up with a blank screen (it did this in Firefox in Windows as well, it was only when I went in IE that it said it was a 406 error)

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2/5.0.45-community/4.4.6/CPG 9.2.0.RC2

All times are UTC