Support ⇒ Troubleshootings ⇒ emailer.php - includes gmail patch on page 2 ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

emailer.php - includes gmail patch on page 2 Reply to topic

Go to page 1, 2, 3, 4 Next

Line : 197
File : emailer.php
General Error
Failed sending email :: SMTP :: Message could not be sent.

Mailer Error: The following From address failed: admin @ potholestudios.com


I know why the error occours, basically, our email system is run by Google Apps, so, thru google mail, but Google mail's anti spam dosent like the fact that Dragonfly is trying to set the from address in the email. even tho the address its sending thru is admin @ potholestudios.com gmail dosent like the custom headers. so basically, what do i need to nerf out of the emailer.php so it will send emails thru the gmail run SMTP server?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


From: is a Custom header?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


You know, Header rewriting, Ever got a spam email, and the from address is your address? Headear Rewriting, and thats what the Gmail servers are not allowing.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


No I don't think that using a From header is a "rewrite".

A "rewrite" can only be forced by using the proper parameter BUT every decent SMTP daemon will add a warning about this into your headers.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I use Gmail and I don't have that problem. Your server should be running your SMTP not Google Aps. That is your server telling you that you have space between the @. (I think).

Are you saying that your server is host on Gmail? Confused

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


No, The web server running Dragonfly is hosted by X-Serverz.

But the Email Server is Google Apps, so google is hosting the @potholestudios.com email addresses. ( mail.google.com/a/poth...tudios.com )

So, in gmail, i enabled pop and SMTP so Dragonfly could interact with the mail server, but every time it tries, it bitches about the email address. (admin@potholestudios.com) "The following From address failed: admin @ potholestudios.com" which is the address that dragonfly is trying to send thru, it just dosent like dragonfly's way of sending mail.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


i Would have edited the last post, but it appears that edit is disabled, so please excuse the doubble post.

But basically, i was just told from a mate who knows about email servers n stuff, that theres a high chance it will be fixed if there is a way to remove dragonflys ability to say what email address it is sending from, which will allow gmail to do it instead.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


Have you contacted Gmail? It looks like that issue needs to be deal with gmail.

And one quick question.

Why do you use Gmail Aps as your default send mail? Your server (X-Serverz) witth your domain should easily do the send mail function. (IE: mail.yourhost.com, smtp.yourhost.com) Or you can even use the php mailer that comes with your server.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


X-Servers mail server... now theres somthing i didnt want to discuss.... No spam protection, i got like 4 spam emails a minute, it constantly goes down, and im planning on moving the website away from them, because in Cpanel, the Server load is allways in the rerad, ive even seen it at "200.0 (4 CPU's)"

Using the PHP mailer in Dragonfly, it cant send to @potholestudios.com because the gmail server rejects it, because the mail says its from an @potholestudios.com address, but the gmail server know it isnt.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


Then you will definately get with Gmail to see if there's a way to get it done.

Lead Theme Designer - WebSiteGuru Designs

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.9 / Apache 2.2.6 / MySQL 5.0.27 / PHP 5 / DF Version 9.2.1


Googles help center says:



If you have a form (using PHP/ASP/etc) on your website that is configured to send a message to your Google Apps email account, but you never receive mail from your website's form, please perform the following tests:

* Send a message to your Google Apps email account from a non-Google Apps personal email account.
* Modify the form to send mail to your Gmail account, or another non-Google Apps personal email account.

If both tests are successful, this issue is most likely caused by mail delivery settings on your webserver. Because your website and your Google Apps email address share the same domain name, the mail agent running on the server that hosts your website thinks that it is responsible for mail addressed to your domain name. This is a typical default setting.

When someone submits the form on your website, the mail agent recognizes your domain name and concludes that it should be sending mail to itself. The mail agent will attempt to deliver the message locally.

To resolve this issue, notify the mail agent running on the server that hosts your website that it is not also responsible for handling mail for your domain. Contact your web host for specific instructions. If you host your own website, contact the support team for your mail server software.


and i have absolutley no idea what the hell its on about.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


DazzaJay wrote
Googles help center says:



If you have a form (using PHP/ASP/etc) on your website that is configured to send a message to your Google Apps email account, but you never receive mail from your website's form, please perform the following tests:

* Send a message to your Google Apps email account from a non-Google Apps personal email account.
* Modify the form to send mail to your Gmail account, or another non-Google Apps personal email account.

If both tests are successful, this issue is most likely caused by mail delivery settings on your webserver. Because your website and your Google Apps email address share the same domain name, the mail agent running on the server that hosts your website thinks that it is responsible for mail addressed to your domain name. This is a typical default setting.

When someone submits the form on your website, the mail agent recognizes your domain name and concludes that it should be sending mail to itself. The mail agent will attempt to deliver the message locally.

To resolve this issue, notify the mail agent running on the server that hosts your website that it is not also responsible for handling mail for your domain. Contact your web host for specific instructions. If you host your own website, contact the support team for your mail server software.


and i have absolutley no idea what the hell its on about.


and concludes that it should be sending mail to itself.

But WHY is it doing that if Dragonfly is set to use a SMTP emailer?
which brings me back to the conclusuin its an issue with DragonFly

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


But WHY is it doing that if Dragonfly is set to use a SMTP emailer?
You setup this up in this way, default is PHP mailer.

It might be better to catch up at Ligon street because I do seriously don't understand what you try to do ....

If you are trying to use gmail as SMTP server then you will not be able to, period. If you have a Goggle mail Premier Edition account then you probably be able to.

To see your self where the error come from and whats the real "raw" error open includes/classes/phpmailer.php and set SMTPDebug (at line 200) to a value of 1,2 or true

Values will give you different debug levels
1: minimum and it will return the errors (preferred)
2: extended and it will return few more infos
true: full SMTP conversation including internal debug (don't use this)

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


The gmail hosted account (admin@potholestudios.com) has POP and SMTP enabled, so the site should be able to send email thru it.

i will try to get the debug message when Ben comes online, so he can help out.

then i will report back.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DebianLenny / Apache2.2.9 / MySQL5.0.51a-24+lenny3-log / PHP5.2.6-1+lenny8 / Dragonfly 9.2.1


Totally forgot. Gmail doesn't use port 25 but it uses TLS connections and since we do not support a STARTTLS command it will impossible to use it.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC
Go to page 1, 2, 3, 4 Next


Jump to: