Dragonfly CMS v9 ⇒ Coppermine ⇒ Batch add doesn't like Firefox 3? ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum Index Modules & Blocks Coppermine

Batch add doesn't like Firefox 3? Reply to topic


anyone else seen this:

I try to batch add a set of 200 photos, and only 3 or so actually get added and bring up OK graphic.

The remainder do not bring up the X graphic, or any graphic at all, they just go back to a normal height line with nothing at the end of it....


It was working much better in Firefox 2, but doesn't seem to play well with 3... I'd rather fix it and keep using 3....

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu bserver 2.6.32-28 / 2.051 / MySQL 5.1.41 / PHP 5.3.2 / Dragonfly 9.3.3


ok... i may have found a solution... info to follow in case anyone else has this problem, or has some input into this...

Firstly - the background reading...
www.tweakguides.com/Firefox_11.html

In particular
network.http.max-persistent-connections-per-server [Integer] (8) - If you are not connected to a proxy, this setting determines how many connections to a single server to keep alive at any time. The default in Firefox 3 is now 6, up from 2, however you can attempt a higher value such as 8 to improve browsing efficiency. The maximum possible is 255, and as mentioned in the settings above, raising this to a very high value will put stress on the particular websites you are connected to and will either result in a refused connection, or slower response times from the web page for every person trying to connect to it. Do not raise this value to one which is very high as it is inconsiderate and counter-productive if everyone does so.


I started out by going to "About:Config" and changing the value of this setting to 10, and noticed that I only got 2 images loading now. So then I reduced it a couple of numbers at a time and ended up at 3, which seems to work fairly well (it loaded 54 images in one go, which is a huge improvement)

Hopefully this works on 200+ photo batches also... I'll find out in about a weeks time, as I have a very busy weekend coming up Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu bserver 2.6.32-28 / 2.051 / MySQL 5.1.41 / PHP 5.3.2 / Dragonfly 9.3.3


Keep us updated Smile

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Well, it's been a while now, and I've had a few decent sized uploads to do in the meantime, and not a sign of this problem...

Looks like it's all sorted Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu bserver 2.6.32-28 / 2.051 / MySQL 5.1.41 / PHP 5.3.2 / Dragonfly 9.3.3


another couple of updates:
1. found that google chrome has a fixed setting for the maximum number of connections that was way too high.. needed to keep a copy of firefox around just to do batch add pics (and one or 2 other things chrome doesn't work with just yet)

2. we moved the sites to a new server not long ago... it now breezes through even in chrome, or in ff on 6 connections or so... however both still struggle at work with big uploads and 6 connections at once, due to the proxy not being able to keep up, however, it is still workable...

so... in conclusion: if you're experiencing this problem, it's most likely to be your servers capabilities, but there's a workaround at hand, if you have firefox... Smile

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Ubuntu bserver 2.6.32-28 / 2.051 / MySQL 5.1.41 / PHP 5.3.2 / Dragonfly 9.3.3


A while ago I've applied a fix that should work with any browser without any tweak. However there are similar reports, a bug report was also filled up and it is still waiting users feedback.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


anyone ever tried if the patch works?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available

All times are UTC


Jump to: