Support ⇒ New installations ⇒ [solved] ERROR: Invalid cookie settings ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

[solved] ERROR: Invalid cookie settings This topic is locked: you cannot edit posts or make replies.

Go to page 1, 2 Next

Hello there,

I am new to try dragonfly Cms and i have some Issues.



In step 4 its says: ERROR: Invalid cookie settings

And i have seach for cookie issues in this forum,but
no one of the posted helped me.


Site Name: Louise Zaar
Domain Name: Louisezaar.dk
Path: /
Administrator Email: lullu @ email.dk
Cookie Domain louisezaar.dk
Cookie Path: /
Admin cookie name: cms_admin
Member cookie name: my_login
Photo Gallery cookie: cpg
Enable Update Service: Yes


This is what stand in the box but it says ERROR: Invalid cookie settings


then i have try to fill the path with /html/Adminstrator
and cookie path with : /home/myname/tmp/sessiondata



bit nothing of this worked.... can somebody help me please?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DragonflyCMS , PHP , Mysql


please search the forums then issue has been covered several times. You will find several threads for this issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Multiple Setups


louisebrinck, you misunderstood the settings

cookie and path are related to the domain name

domain name: bla.com
path: /html/administrator
cookie path: /home/myname/tmp/sessiondata

means your website is located in: bla.com/html/administrator
and the cookie will be valid for bla.com/home/myname/tmp/sessiondata

this is not what you want.

At this stage you need to remove includes/config.php and start over again using "/" for both

Just explain to me what /html/Administrator is for.

As Dizfunkshunal say issue has been covered many times but solution may be different, a little debugging will help me addressing you to the correct solution.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Deprecated: Assigning the return value of new by reference is deprecated in /home/www/mysite.dk/includes/cmsinit.inc on line 189

Deprecated: Assigning the return value of new by reference is deprecated in /home/www/mysite.dk/includes/cmsinit.inc on line 203

Deprecated: Assigning the return value of new by reference is deprecated in /home/www/mysite.dk/includes/cmsinit.inc on line 245

Deprecated: Function ereg() is deprecated in /home/www/mysite.dk/includes/cmsinit.inc on line 28

Warning: date_default_timezone_get() [function.date-default-timezone-get]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /home/www/mysite.dk/includes/cmsinit.inc on line 56

Warning: Cannot modify header information - headers already sent by (output started at /home/www/mysite.dk/includes/cmsinit.inc:189) in /home/www/mysite.dk/includes/cmsinit.inc on line 63

Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/www/mysite/includes/cmsinit.inc on line 68

Warning: ini_set() [ref.outcontrol]: Cannot change zlib.output_compression - headers already sent in /home/www/mysite.dk/includes/cmsinit.inc on line 74

Deprecated: Assigning the return value of new by reference is deprecated in /home/www/mysite.dk/includes/classes/cpg_debugger.php on line 121






It all the time said ERROR: Invalid cookie settings...

Dont know what to do anymore. Im stuck..

somebody please help?

From Louise
/ sorry for my english im not so good at it !

Thanks for help!
tjek this: www.brinckfansite.dk

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DragonflyCMS , PHP , Mysql


NOTE if you are obfuscating your username from the above paths
you MUST change all "/home/www/phpsess" you will found below with "/home/your_uname/phpsess"

Lets start:

Create /home/www/phpsess and, for now, make sure to chmod 777 (world write permission)

Delete /home/www/mysite.dk/includes/config.php

Hit myste.dk/install.php

When you get the error you should be prompted by DF to enter a "php session path" as well; and for this use /home/www/phpsess

Submit again, if it works its all done otherwise keep the window open
ftp to /home/www/mysite.dk/includes/config.php, scroll down till last line
comment out the php session path line and modify the existing path with /home/phpsess

Go back to your browser, make sure you still have /home/www/phpsess on the input field, if not enter it again and hit submit.

Let us know

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Create /home/www/phpsess and, for now, make sure to chmod 777 (world write permission) where could i create that?

chmod 777 (world write permission)

dont know what u mean with that?
could i delete the map config.php from ftp?

Thanks for help!
tjek this: www.brinckfansite.dk

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
DragonflyCMS , PHP , Mysql


Ask your system administrator to setup a different, and working, php session path for you, easy way.

When done, delete config.php and try again.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I am having similar problems and yes I have used search on the forums, there are numerous threads covering this but none give me the clear complete answer I seek.

I am trying to setup a test server.
I have used wampserver, my dragonfly install is at c:\testserver\public_html

I have got as far as step 4 and am now stumped by the ERROR: Invalid cookie settings problem.

Site Name My Dragonfly Site
Domain Name localhost
Path /
Administrator Email admin @ test.com
Cookie Domain /
Cookie Path /
Admin cookie name cms_admin
Member cookie name my_login
Photo Gallery cookie name

I have tried using localhost as domain name, cookie domain, path in numerous combinations but still no progress.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux, Apache 2.0, SQL 5.0.86-log (client: 4.1.22), PHP 5.2.11 DF 9.2.1


@Gamekeeper try the LAN IP

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Thanks for reply, I have tried the LAN IP as Domain name and cookie domain, no luck

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux, Apache 2.0, SQL 5.0.86-log (client: 4.1.22), PHP 5.2.11 DF 9.2.1


All this remind me to change few things inside install.php ...

Before when you try different settings make sure you delete cache/config_MAIN_CFG.php each time, sorry.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Need to know what your php.ini say about

session.save_handler = ?
session.use_cookies = ?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


I to am having trouble getting past the cookie error.
I also have this code at the top of the page:

Deprecated: Assigning the return value of new by reference is deprecated in /home/warillas/public_html/includes/cmsinit.inc on line 189

Deprecated: Assigning the return value of new by reference is deprecated in /home/warillas/public_html/includes/cmsinit.inc on line 203

Deprecated: Assigning the return value of new by reference is deprecated in /home/warillas/public_html/includes/cmsinit.inc on line 245

Deprecated: Function ereg() is deprecated in /home/warillas/public_html/includes/cmsinit.inc on line 28

Warning: Cannot modify header information - headers already sent by (output started at /home/warillas/public_html/includes/cmsinit.inc:189) in /home/warillas/public_html/includes/cmsinit.inc on line 63

Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/warillas/public_html/includes/cmsinit.inc on line 68

Warning: ini_set() [ref.outcontrol]: Cannot change zlib.output_compression - headers already sent in /home/warillas/public_html/includes/cmsinit.inc on line 74

Deprecated: Assigning the return value of new by reference is deprecated in /home/warillas/public_html/includes/classes/cpg_debugger.php on line 121

I have follow NanoCaiordo instructions and have read the other forums and the wikki article and i am still stuck. I have session data but have a cookie error at the necessary info step.

Can i move pass this or manually edit a file to apply these setting?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
unix / Apache 2.2.15 / MySQL 5.0.92 / PHP 5.3.8/ CMS 9.4.0.0


fixed Cheers

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
unix / Apache 2.2.15 / MySQL 5.0.92 / PHP 5.3.8/ CMS 9.4.0.0


same problem.
tried all possible changing browser... erase config, database again and again. Can i somehow skip the cookie check?
I got it installed in 2005 but now a new install failed.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux 2.6.7 i686 - Apache/2.0.54 (Unix) - 4.1.11-Debian_4sarge1 - PHP 4.4.0 [ZE 1.3.0] - 9.0.6.1 - eAccelerator 0.9.3 - (IE 7B1, Firefox 1.61 Alpha2)

All times are UTC
Go to page 1, 2 Next
Post new topic This topic is locked: you cannot edit posts or make replies. Forum IndexNew installations
Page 1 of 2


Jump to: