Miscellaneous ⇒ Server Chat ⇒ Cannot Access Anything After a "Successful" Install? ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexServer Chat

Cannot Access Anything After a "Successful" Install? Reply to topic


All,

Looking for some assistance or guidance from anyone. I just installed Dragonfly 9.2.1 on a Godaddy Linux host site using MySQL 4.1 and PHP 4.x. I had a heck of a time getting it to install until I learned about needing to edit the PHP.INI with a path variable. On my last go, everything went flawless on the install and the install completed correctly.

Now the problem - I cannot access anything at this point. No admin.php access or even the index.php. Im getting the following text error:

--------------------------------
Eader from script. Bad header=INCLUDED 403 Forbidden
The URL that you requested, /admin.php, resulted in a server configuration error. It is possible that the condition causing the problem will be gone by the time you finish reading this.

We have logged this error and will correct the problem.


Please return to the homepage
--------------------------------

You can see for yourself by pointing your browser at wolf-guild.info.

Im not a web dev or coder, so Im probably overlooking something simple.

Any ideas on how I can solve this? Im looking to get the site up and then add in the Roster Master for Dragonfly (RM4DF) module next.

Any help or guidance is highly appreciated....

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1

Last edited by gamponia on Tue Feb 16, 2010 5:03 am; edited 2 times in total


Hi,

firstly I need to know what exactly you modified in php.ini

then, I believe, your files become UTF8 BOM encoded probably by mistake because you are using windows vista, windows 7 or a text editor with UTF8 BOM enabled. The correct encoding should be UTF8 without BOM, known in some application as UTF8 as ANSI.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


NanoCaiordo

Ill post my php.ini when I get home this evening. the PHP versions and the INI were part of my initial install problems. I had in multiple reinstall attempts deleted the default php.ini and finally went to another linux Godaddy hosting page I have and downloaded its starting php.ini and then modified using Ultraedit editor to add the session.save_path entry. I am using Win7 Pro (64bit) at home to do my work.

I had also swithced to PHP 4.x vice the 5.x i was initially using when I had the install problems.

Based on your feedback, you believe that when I modified the php.ini that I downloaded from the other GoDaddy linux hosting page and edited in UltraEdit, I let UltraEdit encode incorrectly with the BOM? Will have to see if UE can properly encode?

Will respond with the php.ini content ASAP.

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


NanoCaiordo

I have the PHP.INI attached that I have right now on the hosting site (named PHP.INI).

I re-downloaded a clean source GoDaddy default PHP.INI this evening and then took the additional entries of SESSION and MAGIC QUOTES and added the via copy & paste into the clean file. I then saved in UltraEdit using SAVE AS with the following settings:

Line Terminator: UNIX Termination - LF
Format: UTF8 - no BOM

I uploaded the attached file to the hosting root, deleted the old suspect INI file and renamed this one to PHP.INI.

No joy.

Thoughts or suggestions on how to figure this out and make it work?

thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Attaching the php.ini file with a TEXT suffix

OK - cant even manage to attach file.... content is shown below:

------------------------------------------
register_globals = off
allow_url_fopen = off

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

[Session]
session.save_path = /tmp

[Magic quotes]
; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off
; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_runtime = Off
; Use Sybase-style magic quotes (escape ' with '' instead of \').
magic_quotes_sybase = Off
------------------------------------------------------

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Just visited your website but all I get its a parked domain page.

THis kind of error its very hard to debug so we need many details as possible.

The exact error.
Exact php/apache verion used.
Windows, Linux, BSD server?
PHP installed as CGI binary or apache module?
Is Apache loading WebDAV module as well?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


NanoCaiordo

OK - here is the current scenario. I also began to suspect something had gone worng during install or editing of a file due to the fact that my "successful" install was probably on try #15 or so, so i wiped the site completely (deleted all files), deleted the one configured DB, and reinstalled from scratch. I also wiped my own unzipped directory of DragonFly CMS files and newly unzipped the Dragonfly download files. I called GoDaddy and they helped me restore the default files in the hosting directory and the starting PHP.INI. This is where you saw the hosting parked web page.

I next re-FTPed all of the files from my system to the hosting site root.

I edited a clean copy of the original PHP.INI to include the session.save_path and the magic quotes entry. I CHMODded the directories and file as directed in the NEW INSTALL instructions.


I began the INSTALL from scratch exactly per the instructions,

The initial server settings were all GREEN. The exact statistics are on the bottom of this posting.

The install went flawless through the server assessment, the SQL connection test and a successful SQL server SAVE; the begin database configuration; the building of the database; and the "lets setup some necessary information screen! At soon as I entered the necessary info and clicked SUBMIT on the INSTALL.PHP screen, (STEP 3) just at the cookie test, the IINSTALL.PHP flashed directly back to the beginiing, indicating "You already have DragonFly 9.2.1 installed.

Im at that point right now. It wont let me continue and run the INSTALL.PHP.

If I go to the root of the hosting site with a browser right now, I get the exact same header error below that I had after what I believed to have been a successful installation previously.

The error is:
________________
Eader from script. Bad header=INCLUDED 403 Forbidden
The URL that you requested, /, resulted in a server configuration error. It is possible that the condition causing the problem will be gone by the time you finish reading this.

We have logged this error and will correct the problem.
__________________
Same goes for trying to access the ADMIN.PHP file, though I also never successfully setup the admin account.


GoDaddy LINUX hosting
PHP 4.4.9
GD 2.0.28
MySQL 4.1

PHP installed as CGI binary or apache module? - unknown. Im not certain how I can determine and my searching of GoDaddy information has not provided that information.
Is Apache loading WebDAV module as well? - unknown. Im not certain how I can determine and my searching of GoDaddy information has not provided that information.

Thats where I am right now. How should I proceed? Up to now, I had been deleting the /includes/config.php file and trying to work through the error?

Thoughts?

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Updated information on the GoDaddy Linux hosting configuration with respect to PHP and Apache:
____________________________________________
For security reasons, we run PHP as a CGI and not as a module. Because of this and the version of Apache we run (1.3.3), you cannot use extensionless PHP files on your website without employing a tool like mod_rewrite.
____________________________________________

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Follow on thought/question:

On the installation step of gathering some necessary information, I had been leaving the PATH as the default "/" and the COOKIE PATH as the default "/".

The default GoDaddy PHP.INI has the entry of:
upload_tmp_dir = /tmp
and I add in the entry:
session.save_path = /tmp

However my root when I FTP into the hosting site does not have a "tmp" directory.

My ABSOLUTE HOSTING PATH is: /home/content/w/e/b/webpuppy/html

Should I be placing my absolute path plus /tmp into the install PATH entry and also creating a tmp directory with a CHMOD 755?

Just trying to puzzle this out. Many thanks for putting up with these questions.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Is it possible for GoDaddy to disable mod_layout on your site or its free hosted?

Since PHP run as CGI binary you must be careful whit CHMOD, if paths or files permissions are too open then you'll get similar errors.

create /home/content/w/e/b/webpuppy/tmp
session.save_path= /home/content/w/e/b/webpuppy/tmp

test by uploading or creating an empty folder and check the permissions applied to the folder, it should be 755.
If so change all 777 back to 755.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


And make sure your FTP client knows the difference between text and binary files.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


OK - Im running out of ideas.

I wiped down to the ground again, re-uploaded a clean load and then created the tmp under the root. GoDaddy has a graphical interface for everything, so I use SmartFTP client from my computer to access and upload the files. SmartFTP is set to AUTO on transfer type - says it uses binary tranfer to non-Windows platforms as default except for files matching an ASCII file list. The default initial permissions are 705 for a TMP directory. I use SmartFTP to CHMOD to 755 and when I then create a directory below, it correctly shows inhereting the 755 permissions.

So... I follow the installation instructions and CHMOD the permissions to 755 for the cp_error.log and the remaining five directories. I ONLY change the directory permissions, I am not applying recursively to change existing files in the directory, but it appears all new files inheret the correct 755 permissions.

I have a clean database now and I modified the PHP.INI with the full absolute hosting path to the tmp directory for the session.save_path entry.

Now I am back to my original installation problem, where I am not successfully making it through the installation - the install gets to the TRYING TO CONNECT TO SQL SERVER - SAVING CONFIGURATION SUCCEEDED and then it reverts right back to the beginning License Agreement Screen. It goes in a big circle and I have not managed to get past that point.

I have not found the answer to the disabling of mod_layout on GoDaddy - should I pursue by calling them on that subject?

Im open to any suggestions - this is hugely frustrating, but I want to solve this and come out on top...!

Thoughts?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


As far I can tell even if we are able to patch your installation you will probably have problems with modules or blocks .. who knows.

If its a free hosting package or a very cheap one you will get more headaches then anything else, consider switching host.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


I have a number of other resources consolidated with GoDaddy, so unless its my last resort, I'd rather not. The machines work for us, not the other way around - there has to be a reasonable way to achieve success. Im just not sure if my own lack of in-depth knowledge on this is the hinderance.

Having said that, what hosting sites are known compatible and perhaps recommended for DragonFly CMS?

My underlying goal is to get the RosterMaster module for DragonFly operational. Is it specific to only DragonFly CMS?

There has to be other DragonFly CMS users who are hosting on GoDaddy that can potentially assist and let me know what they went through to make it work?

I noticed tonight that GoDaddy through its graphical hosting interface sets all PHP scripts in its root as "web visible" and "executeable" in its simplified permissions scheme. When I upload the DragonFly files, their CHMOD value as seen through SmartFTP is 604 but from within the hosting interface, they do NOT have the "executeable" icon marked, only the "web visible" icon. I wonder if I need to set much greater permissions through the simplified hosting interface than just the basic CHMOD changes that are called for in the install procedures.

If i could manage to attach files to these postings, Id attach some more in-depth example screen shots and info that might allow someone with more experience to spot what I am doing wrong?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Red Hat Linux (GoDaddy host) / Apache 1.3 / MySQL 4.1 / PHP 4.3.11 / CMS 9.2.1


Try to CHMOD all files to 644 and all directories to 755.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head

All times are UTC


Jump to: