Miscellaneous ⇒ Server Chat ⇒ slow page loads - high server load ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexServer Chat

slow page loads - high server load Reply to topic


I noticed that recently my website is experiencing slow page loads. I'm running on dedicated server I have < dozen websites on it. The biggest site (DF CMS) and it has over 9000 members. The other sites are non significant. I'm running CentOS, 2.4Ghz Celeron, 2GB RAM, Cpanel/WHM, PHP5 and mySQL 5.0.92.

What can I do to optimize my server settings to make the website faster?

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


Not easy to tell, a software or a server can be slow for way too many reasons.
You need to debug, then act accordingly to your findings.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


NanoCaiordo wrote
You need to debug, then act accordingly to your findings.

What would be the best way of debugging? DF software has not changed on the server. Only server OS and CPanel upgrades are being done automatically. I'm simply looking for some server optimization help.

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


In this case there is not "simply", look at the process list "ps aux" or use "top" ... these are basic commands. Hope it helps.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.7 / PHP 7.3 / head


Are there any tweaks that you recommend in the "PHP Configuration Editor"?

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


it worked for me a while ago

if a table has PRIMARY KEY(id) and it also have UNIQUE KEY(id) then you have to delete the UNIQUE KEY

www.mysqlperformancebl...t-indexes/

Older versions of DF had this, new one doesn't

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available


Is that an issue on DF v9.2.1? If so, how do I fix this?

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


i don't know when it got fixed, perhaps CVS logs or changelogs may help

to delete them just use phpmyadmin, but make sure you understand what you need to delete I get no responsibility at all here

delete the UNIQUE KEY only if a PRIMARY KEY exists already for the same key

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available


Man, this site loads VERY fast. You think that the Developers would have their settings posted here so others can optimize their Dragonfly websites properly. Maybe such guide exists but I just don't know about it? I'm pulling my hair out here. Any assistance would be greatly appreciated.

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


SnoSheriff wrote
Any assistance would be greatly appreciated.
have you done any of what we asked? if not why, if yes what's the result?

you obsessed by php settings, i'll post mine when i can

but i know some servers have output compression (if this is the one, anyway it does have something to do compression or gz) enabled, disable that if enabled.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available


PRIMARY KEY(id) and it also have UNIQUE KEY(id) then you have to delete the UNIQUE KEY

This sounds like DF software bug. I'm running the latest release v9.2.1. I'm not running CVS mode on my site so what is the best way to get this fixed?

Nano wasn't specific about what I need to look for. Keep in mind that I'm not a Linux Admin or PHP Developer. I know SQL and some coding but I'm not an expert programmer or administrator.

I need more concrete directions like:
Change Value X to X2 in Section A.
Run ABC and post first 10 lines...

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


Not obsessed, just poking around and looking for direction and recommendations.

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1


ssh into the server and type "top" (no quotes), by default process lists are ordered my cpu usage, have a look whats the process using more cpu

if is mysqld then: use phpmyadmin to delete duplicate keys

a bug in DF ... i think it was a phpnuke or an installer issue, supposed to be fixed in new DFs, but i guess an old bug in phpmyadmin shuffled things around confusing the water

nano said there is not "simply" here, well he does have a point and "change A to B" can't be easily done ... experienced debuggers with shell access may take few minutes to understand where the problem come from, and sometime to fix it

we going totally blind here I'll be surprised if we gonna be able to fix it

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available


I watched the TOP process run on the screen. CPU % increased when I saw 5 PHP processes being at the top of the list.

I also set my DF Security as per the attachment. When I had the Unkown User-Agents set to active my site users were receiving banned messages. "Unkown User-Agents"=Active increased the site performance but I had to deactivate it because the users were unable to access the site.
Attachment: df-security.jpg
Description
Filesize 40.99 KiB
Viewed 1 Time(s)
You are not allowed to view/download this attachment

XJBikes.com

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache=1.3.41/MySQL=5.0.87-community/PHP=5.2.6/DFCMS=9.2.1

Last edited by SnoSheriff on Mon Apr 04, 2011 11:29 pm; edited 2 times in total


in php.ini
output_buffering 0

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
none available

All times are UTC


Jump to: