Support ⇒ Upgrades ⇒ [solved] Ugrade DF to 9.3.2.0 Maintenance error ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

[solved] Ugrade DF to 9.3.2.0 Maintenance error Reply to topic


Hi.
I got Maintenance when I try login to admin.php

Read that
UPDATE `cms_config_custom` SET `cfg_value` = '0' `cfg_name` = 'global' AND `cfg_field` = 'maintenance' LIMIT 1;

is the solution, but I got this error: #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '`cfg_name` = 'global' AND `cfg_field` = 'maintenance' LIMIT 1' at line 1

Any known bugs i this DB string.
Got same error on cmd line and using phpmyadmin

Pls hlp
/Brian

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
SuSE Linux 11.1 Linux 2.6.27.56-0.1-pae on i686 Apache version 2.2.10 MySQL version 5.0.67 PHP 5.2.14-0.4.1 DF 9.3.2.0


Your are mixing back ticks with single quotes but you also forgot to add WHERE in the query

set cfg_value=0 WHERE ....

You can also login as admin and disable the maintenance option from admin -> main settings -> maintenance.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


NanoCaiordo wrote
Your are mixing back ticks with single quotes but you also forgot to add WHERE in the query

set cfg_value=0 WHERE ....

You can also login as admin and disable the maintenance option from admin -> main settings -> maintenance.


My problem is, when I try to acces admin.php I got the "Maintenance" and can´t login at all.
I´m NOT a db specialist, and did find the db sting somewhere, but can you be nice and correct that string to me ?

/Tnx

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
SuSE Linux 11.1 Linux 2.6.27.56-0.1-pae on i686 Apache version 2.2.10 MySQL version 5.0.67 PHP 5.2.14-0.4.1 DF 9.3.2.0


UPDATE cms_config_custom SET cfg_value='1' WHERE cfg_name='global' AND cfg_field='maintenance' LIMIT 1;

Then, delete ./cache/config_MAIN_CFG.php.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


NanoCaiordo wrote
UPDATE cms_config_custom SET cfg_value='1' WHERE cfg_name='global' AND cfg_field='maintenance' LIMIT 1;

Then, delete ./cache/config_MAIN_CFG.php.



Hi again.....

It works !!!! You are the man... THANK YOU

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
SuSE Linux 11.1 Linux 2.6.27.56-0.1-pae on i686 Apache version 2.2.10 MySQL version 5.0.67 PHP 5.2.14-0.4.1 DF 9.3.2.0

All times are UTC


Jump to: