Support ⇒ Upgrades ⇒ [fixed] Removal of & from email links ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

[fixed] Removal of & from email links Reply to topic


hi all i have my site setup but when i get an e-mail with a link i click it and it goes to the forum home page i.e

www.league.vivahosting...&p=4#4

and not

www.league.vivahosting...&p=4#4

anyone know how get rid of the amp; in the email?

Regards,

Cprl.Rst
{image removed - please observe our Rules}

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.3.3.0


URLs are the same, use [code] or other bbcode's tags to prevent html special chars to be parsed or space & amp

Also will help to know if you are using Dragonfly built-in forums, or others.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


There was a large update for sub forums about 30 months ago that introduced that issue, and it seems I overlooked fixing it in the original v9 forums (not an issue in v10 or ForumsPlus).

In 9.3.2.0 replace includes/phpBB/functions_post.php, lines 418 and 419, with:
'U_TOPIC' => getlink('&file=viewtopic&'.POST_POST_URL."=$post_id", true, true)."#$post_id",
'U_STOP_WATCHING_TOPIC' => getlink('&file=viewtopic&'.POST_TOPIC_URL.'='.$topic_id.'&unwatch=topic', true, true)

DonationsPro for DragonflyCMS & SMF

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


i'll give that a try

Regards,

Cprl.Rst
{image removed - please observe our Rules}

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
9.3.3.0

All times are UTC


Jump to: