Support ⇒ Upgrades ⇒ [solved] My site will not load ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

[solved] My site will not load Reply to topic


Sup folks, I'm fairly new to mySQL and PHP. After installing Dragonfly CMS 9.3.3.0 to my host. The website came up and I was working on it. Then I keep getting pop up messages saying something like bad link "/public_html/admin.php" or something. After changing some stuff around (try to remove the front page news), now my home page says "Page 1 does not exist". Then I went into "Dragonfly 9.3.3.0 Web Site Configuration" To see if I diabled something by accident. So I saw my Administrator Email was incorrect, so I changed that and hit the save changes button. Now my website shows nothing but boxes with X's and a list of my link. If anyone can help guide me through this, I will appreciate that very much.

BTW, my web link bassfishing.webege.com/

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2.2.19 (Unix)/MySQL 5.1/PHP 5.2.*/DragonflyCMS 9.3.3.0

Last edited by wingz on Fri Jan 27, 2012 10:06 pm; edited 1 time in total


Hello,

Concerning the message "Page 1 does not exist" it simply means that your homepage module ist the news module but currently there are no news to be displayed. This is due to the fact that there are no news at all if you deleted them all.

When trying to call the admin.php page i indeed get the X's displayed. It seems you have installed DragonFly in a subfolder of your hosting. Be sure to set this subfolder accordingly in you dragonfly settings. It appears this have to be "public_html"

Hope this helps.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.1.49/PHP 5.3.6/ DF 9.3.2.0


oh, if you cannot access anymore to your dragonfly configuration you can try to modify the path parameter directly in you database. The table you should look for it is called cms_custom_config assuming that you preserved the default table prefix "cms".
The record you should look after is cfg_name=server and cfg_field=path and you must put public_html in the cfg_value field

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.1.49/PHP 5.3.6/ DF 9.3.2.0


Ok, the value was "/public_html/" and I changed it to "public_html" (without the back slash//)(**if that matters). The website still looks the same and my website looks like the screen shot this person posted.
( dragonflycms.org/Forum...c/t=21686/ )

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2.2.19 (Unix)/MySQL 5.1/PHP 5.2.*/DragonflyCMS 9.3.3.0

Last edited by wingz on Fri Jan 27, 2012 10:45 pm; edited 1 time in total


If you are not skilled to make modifications in phpmyadmin don't try it.

Try a fresh installation, simply drop all the database tables and launch the DragonFly installer again. Make sure to enter the good path to the subfolder your files are stored and all should work fine.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.1.49/PHP 5.3.6/ DF 9.3.2.0


Yea, I've installed dragonfly 3 times with same results. Here is what I did. Since the dragonfly files come in the folder call "html" I change it to "public_html" before uploading it to the root? Because for some reason my host does not reconize "html". During the installation, I enter "public_html" for the path to website. Then I leave the cookie blank, because I dont know what to put there. After creating a Super User, I enter the site and started to edit the features. Apon saving the section that you can edit path/site slogon/LEO (enable/disable)mabye admin.config, thats when the site looks the way it does and starts to have all these link errors.

If you see a mistake I made along the lines, please let me know and thanks for your guide.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2.2.19 (Unix)/MySQL 5.1/PHP 5.2.*/DragonflyCMS 9.3.3.0


Your site should have been installed in the /home/whatever/public_html/ directory - this is where the DF folders and index.php etc should be.

admin.php?op=settings
Site Domain: bassfishing.webege.com
Site Path: /

admin.php?op=settings&s=2
SERVER_NAME: No
Cookie Domain: bassfishing.webege.com
Cookie Path: /
Admin Cookie: cms_admin (must not be blank)
Member Cookie: cms_login (must not be blank)

If you install in the directory I mentioned at the top, DF will do this automatically for you.

If you reinstall, remove all files in the /public_html/cache/ folder EXCEPT for the .htaccess file.

dragonflycms.org/Wiki/id=47/

DonationsPro for DragonflyCMS & SMF

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Ok, I think I found the mistake. during installation under "Site Path: /" I put "/public_html". So far its looking good.

www.huntandfishing.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache2.2.19 (Unix)/MySQL 5.1/PHP 5.2.*/DragonflyCMS 9.3.3.0


i'm sorry about spreading wrong information around. I missunderstood the situation. really sorry.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Linux/Apache/MySQL 5.1.49/PHP 5.3.6/ DF 9.3.2.0


All good mate, we all get it wrong sometimes.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS

All times are UTC


Jump to: