Support ⇒ Upgrades ⇒ Column 'filename' cannot be part of FULLTEXT index ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

Column 'filename' cannot be part of FULLTEXT index Reply to topic


I hate to bump an old thread, but I just got this trying to upgrade to 9.3.3.0. I double checked my db and everything is showing up as ut8f_general_ci.

Here is my log output:

coppermine tables:
cpg_albums columns: . . . . . . . . . . . . .
cpg_albums indexes: . .
cpg_categories columns: . . . . . . . . . .
cpg_categories indexes: . . . .
cpg_comments columns: . . . . . . . . .
cpg_comments indexes: . .
cpg_config columns: . .
cpg_config indexes: .
cpg_exif columns: . .
cpg_exif indexes: .
cpg_installs columns: . . . .
cpg_installs indexes: .
cpg_pictures columns: . . . . . . . . . . . . . . . . . . . . . . . . . . .
cpg_pictures indexes: . . . . . . .
cpg_usergroups columns: . . . . . . . . . . .
cpg_usergroups indexes: .
cpg_votes columns: . . .
cpg_votes indexes: . .
cpg_config content: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Executing the queries: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .


Column 'filename' cannot be part of FULLTEXT index

Please contact the CPG-Nuke Dev Team about the error
You cannot continue with the installation




Ideas? I'm stuck Sad

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS:Linux/Apache:1.3.33 / MySQL:5.0.51a / PHP:5.2.6 / DF 9.2.1


Back in the days when we moved to fully support UTF8, there it was another small step that some user had to go trough.

As you stated the database collation is utf8, but what about the tables?

Skipping to the possible workaround, open config.php and look for

define('DB_CHARSET', 'utf8'); // NULL (is default), latin1, utf8, etc.

If ` NULL ' set to ` "utf8" ', or the other way around.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


No, there is nothing in the config.php for that.

While Phpmyadmin is showing everything being utf8, I did dump the db as a sql file and load it up in a text editor, and found some references to latin1. I tried to set it to ut8f_general_ci and re-import into phpmyadmin but it puked due to the DB being too large to upload, so I tried compressing it and uploading it, it puked on a duplicate primary key query in the administrator array.

I threw in the towel for the evening and requested my webhost restore the site from the pre-upgrade backup I had created. Those morons only partially restored it as I am getting errors now of missing php files and misc images. The morons then deleted the backup so I cant even selectively restore missing things.

I'm putting the upgrade on hold for now and am just attempting to get back to a working state in 9.2.1.

Really really frustrated today /sigh.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS:Linux/Apache:1.3.33 / MySQL:5.0.51a / PHP:5.2.6 / DF 9.2.1


I'm not seeing the 9.2.1 archive in the downloads anywhere. Is it still around so I can download it?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS:Linux/Apache:1.3.33 / MySQL:5.0.51a / PHP:5.2.6 / DF 9.2.1


If the config.php is missing that line, add it please.

All troubles may go away by simply doing that, is this a 8.2 original website?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


It is an original 8.2 install.

The site is currently completely trashed from a restoration gone bad (one of their techs screwed up). My webhost is currently restoring the site from a previous major backup on their end. Hopefully that will complete in the next hour or two (its a huge site hehe)

Anyway when I get back to a running state, I will revisit this thread and most probably, set up a copy of the site somewhere else and test installation issues there before attempting an upgrade on my live site.

Thanks

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS:Linux/Apache:1.3.33 / MySQL:5.0.51a / PHP:5.2.6 / DF 9.2.1


As i believe, the missing line in the config.php could make the diff.

This is what config.php looks like today, add missing data.

<?php
/*********************************************
  CPG Dragonfly CMS
  ********************************************
  Copyright (c) 2004 - 2005 by CPG-Nuke Dev Team
  dragonflycms.org

  Dragonfly is released under the terms and conditions
  of the GNU GPL version 2 or any later version

  $Source: /cvs/html/install/config.php,v $
  $Revision: 9.4 $
  $Author: djmaze $
  $Date: 2006/01/07 23:53:23 $
**********************************************/
if (!defined('CPG_NUKE')) { exit; }

define('DB_TYPE', 'mysqli');
define('DB_CHARSET', 'utf8'); // NULL (means default), 'latin1', 'utf8', etc.
$dbhost = 'removed for post purposes';
$dbname = 'removed for post purposes';
$dbuname = 'removed for post purposes';
$dbpass = 'removed for post purposes';
$prefix = 'removed for post purposes';
$user_prefix = 'removed for post purposes';

# -- $adminindex -----------------------------------------
# The filename of the admin index page I'd like to use for
# my site
#
# If you change this to something other than it's default
# value, you must also rename the file called 'admin.php'

# to the new value you assigned to this variable
#
# default: admin.php
# --------------------------------------------------------
$adminindex = 'admin.php';

# -- $mainindex ------------------------------------------
# The filename of the main index page I'd like to use for
# my site
#
# If you change this to something other than it's default
# value, you must also rename the file called 'index.php'
# to the new value you assigned to this variable
#
# default: index.php
# --------------------------------------------------------
$mainindex = 'index.php';

# -- admin demo mode -------------------------------------
# Alter the following value to activate the administrative
# system demonstration mode, enabling my users to browse
# my administration menu in a read-only environment
#
# true  = enabled
# false = disabled
#
# default: false
# --------------------------------------------------------
define('CPGN_DEMO', false);

# -- debug mode ------------------------------------------
# Alter the following value to activate debug mode, which
# will show debug messages to all users, instead of
# administrators
#
# Warning: Enabling debug mode is NOT recommended for
#          production websites
#
# true  = enabled
# false = disabled
#
# default: false
# --------------------------------------------------------
define('CPG_DEBUG', false);

# --- WARNING --------------------------
# Do not touch anything below this point
# unless you know what you're doing
# --------------------------------------

$CensorList = 'removed for post purposes';
$DeniedUserNames = 'removed for post purposes';
//session_save_path('/home/SOMETHING/tmp');

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Thank you for the help. My site was restored last night (what an unbelievable nightmare that was) so I'm back to at least the pre-upgrade standpoint.

Going forward I am next going to set up a copy of my site running elsewhere, or on a old testbox in my house, then I can experiment with the upgrade without any loss of downtime. I will use your above examples to see if it solves the issue.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
OS:Linux/Apache:1.3.33 / MySQL:5.0.51a / PHP:5.2.6 / DF 9.2.1


Pretty common issue with older databases upgrading these days.

I opened my sql file in notepad and simply ran a replace all on "latin1" with "utf8", seemed to get us out of trouble.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
2.6.18-164.11.1.el5xen/2.2.13/5.0.89-community-log/5.2.11/9.3.3.0

All times are UTC


Jump to: