Support ⇒ Upgrades ⇒ [revived] zero in new users signature ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexUpgrades

[revived] zero in new users signature Reply to topic


Archived topic has been revived »» dragonflycms.org/index...mp;t=18870

macavity wrote
I ran into a similar issue with the "My Location" field and the DFmaps module which was related to the relevant field in the users table being pre-filled for the Anonymous user. Looking at the users table again I note that there's a zero in the user_aim field so I guess that might be the cause of this problem?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly (9.3.4.1)


For anyone else who still gets the 0's as default in the New User signup page I've come up with a simple fix.

Modules\Your_Account\functions.php

Change

else if ($type == 2) { return '<textarea name="'.$field.'" style="width: 300px" rows="6" cols="30" class="post">' if ($userinfo[$field] == NULL).htmlprepare($userinfo[$field]).'</textarea>'; }

to

else if ($type == 2) { $currentpage = $_SERVER['REQUEST_URI']; if ($currentpage == '/Your_Account/register/agreed=1.html') { return '<textarea name="'.$field.'" style="width: 300px" rows="6" cols="30" class="post"></textarea>'; } else { return '<textarea name="'.$field.'" style="width: 300px" rows="6" cols="30" class="post">'.htmlprepare($userinfo[$field]).'</textarea>'; }

This will work aslong as you have Activate Link Engine Optimization (LEO) enabled

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Dragonfly (9.3.4.1)

All times are UTC


Jump to: