Support ⇒ New installations ⇒ Cannot add super admin in a brand new 9.3.4.1 site ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexNew installations

Cannot add super admin in a brand new 9.3.4.1 site Reply to topic


So when I try to add a super admin, this is what I get:

Please include at least one number, one capital letter and one lowercase letter in your password

And I am doing exactly that - and it still says the same thing. Any ideas?

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
[ Linux / Apache 2.2.8 / MySQL 5.0.45 / PHP 5.2.6 / CPG 8.2b - 9.3.4.1]


Go to admin/modules/admins.php:33 (line 37 if you using the CVS version) and replate that line with
if (!preg_match('#[0-9]#', $_POST['add_pwd']) && !preg_match('#[a-z]#', $_POST['add_pwd']) && !preg_match('#[A-Z]#', $_POST['add_pwd'])) { cpg_error(_PASSWORD_MALFORMED, _CREATIONERROR); }

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


That worked!

So the version I used I had *just* downloaded from this site last night ... so that might need to be fixed in the versions that you are offering for download.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
[ Linux / Apache 2.2.8 / MySQL 5.0.45 / PHP 5.2.6 / CPG 8.2b - 9.3.4.1]


I am suffering from this issue. The suggested fix has not work in my case! Any additional suggestions?

It occurs for all admins I try to add not just super users.


All better now I had the non CVS version and I needed to replace line 33.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
unix / Apache 2.2.15 / MySQL 5.0.92 / PHP 5.3.8/ CMS 9.4.0.0

All times are UTC


Jump to: