Support ⇒ Troubleshootings ⇒ DragonflyCMS not available when using IE8 ⇒ Community Forums ⇒ CPG Dragonfly™ CMS
Forum IndexTroubleshootings

DragonflyCMS not available when using IE8 Reply to topic


With IE8 and with firefox on android, my dragonflyCMS did not work.

Therefore, I've tested with DragonflyCMS built from scratch here:
www.livois.com/famille_test/

You can see the pages when you use Firefox but get some weird characters with IE8 or androoid phones.

Here's some technical information:
CMS Version 9.3.4.1
PHP Version 5.4.4-12
MySQL Version 5.5.28-1-log (client: 5.5.28)
Server API FPM/FastCGI
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, zip, phar, ssh2.shell, ssh2.exec, ssh2.tunnel, ssh2.scp, ssh2.sftp

Does anyone have the same problem? Do you have any ideas to solve the problem?

Christophe

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux gentoo/apache2/mysql5.0/php5.2/dragonflycms 9.1.2.1


cant really see it since it is in maintenance

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
Multiple Setups


Have you uploaded the site in the right modes?
text,php files on ascii mode, and not in binary?

www.greenday2k.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Thanks for your help. I have the same problem whether I am on maintenance mode or not. It's just that IE8 doesn't show html but weird characters.

The FTP upload is automatic. It's ASCII for php.
The site is wery well seen by firefox on a computer (but not on an Android smartphone)

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux gentoo/apache2/mysql5.0/php5.2/dragonflycms 9.1.2.1


I tried your site (in maintenance) with firefox on android and was ok on my side, also tried on android VM and still no issues ?!?

On firefox + android there is a setting to "show enconding in menu" or something similar, select it.

Firefox menu again and you will see a new entry "Encoding", originally set to ANSI, try to manually set UTF-8.

As a side note, I had no issues in with both.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


On win / with:
Chrome: weird characters.
Firefox OK
Safari: weird characters.
Opera Mobile: weird characters

After checking your site with validator.w3.org
validator.w3.org/check...mp;group=0


Conflict between Mime Type and Document Type

The document is being served with the text/html Mime Type which is not a registered media type for the Document Type. The recommended media type for this document is: application/xhtml+xml

Using a wrong media type for a certain document type may confuse the validator and other user agents with respect to the nature of the document, and you may get some erroneous validation errors. How to fix this problem? One of the following techniques should help:

If you are serving a static file on a Web server, changing its extension should help. Use e.g .xhtml for XHTML or .mml for MathML.
You may need to reconfigure your Web server. This Setting up MIME Types tutorial has instructions for Apache, Tomcat and IIS.
If the document is generated dynamically, the scripting language should allow you to set up the mime type: this article on MIME Types and Content Negotiation has examples in PHP, Perl, and ASP.

Mismatch between Public and System identifiers in the DOCTYPE declaration

This document uses an inconsistent DOCTYPE declaration. The Public Identifier -//W3C//DTD XHTML 1.1 plus MathML 2.0//EN declares the XHTML 1.1 plus MathML 2.0 document type, but the associated System Identifier www.w3.org/TR/MathML2/...th11-f.dtd does not match this document type.

The recommended System Identifier for XHTML 1.1 plus MathML 2.0 is www.w3.org/Math/DTD/ma...h11-f.dtd.

The safest way to use a correct DOCTYPE declaration is to copy and paste one from the recommended list and avoid editing that part of your markup by hand.

No Character encoding declared at document level

No character encoding information was found within the document, either in an HTML meta element or an XML declaration. It is often recommended to declare the character encoding in the document itself, especially if there is a chance that the document will be read from or saved to disk, CD, etc.



www.livois.com/famille_test/

www.greenday2k.net

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):


Sorry greenday2k but it's not related to the issue, check df.org index.php&prevtheme=default and you will get the same warnings without encoding issues.

1. Apache 2.4
2. Varnish proxy
3. an initial Content-Encoding header set to gzip, and a second one "empty" (should be the way around)

As happened before, try to comment-in the empty Content-Encoding header found at cmsinit.inc:84.

if (ini_get('output_buffering')) { ob_end_clean(); // header('Content-Encoding: none'); // header('Content-Encoding: '); << this is line 84 }
I suppose the proxy or apache are not maintaining the order of sent headers.

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Thanks for your answers.
It works with android browser with cmsinit.inc change to:

header('Content-Encoding: none');
// header('Content-Encoding: ');


I still need to check for IE8 but I guess it should be working also.

Thanks again!

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux gentoo/apache2/mysql5.0/php5.2/dragonflycms 9.1.2.1


By doing so you lost gzip compression, did my version worked or not?

.:: I met php the 03 December 2003 :: Unforgettable day! ::.

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
CloudLinux / Apache 2.4 LSAPI / MySQLi 5.6 / PHP 5.6 / DCVS


Just in case anyone is struggling with this same issue (as we were for a very long time before finding this thread) I can confirm that commenting out the line Nano refers to above does indeed solve this problem and allows gzip compression to be implemented (previously we had to turn it off by adding 'SetEnv no-gzip dont-vary' to our .htaccess file but that's no longer necessary - yippee!)

Note: WWW Private Listing - Staff Only

Server specs (Server OS / Apache / MySQL / PHP / DragonflyCMS):
linux/Apache 2.4.27/MySQL 10.1.26-MariaDB/PHP 5.2.17/Dragonfly 9.2.1

All times are UTC


Jump to: